Форум клана ЧПУшников

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » Форум клана ЧПУшников » Станки с ЧПУ » По оси х едет только в одну сторону.


По оси х едет только в одну сторону.

Сообщений 1 страница 43 из 43

1

Уважаемы форумчане подскажите пожалуйста в чем может быть дело. После небольшого перерыва привез станок в новое место и попытался включить. Станок BZT работает от Mach3. Ось x нажимаю и в право и в лево едет в одну сторону. Такая же беда и с осью z. Одна ось y правильно двигается. Уже голову сломал. И пины выставлены,  и даже горячии клавиши посмотрел. Ничего не помогает. Кто сталкивался с подобной проблемой или знает что нужно сделать подскажите пожалуйста.

0

2

Alex83 написал(а):

Уважаемы форумчане подскажите пожалуйста в чем может быть дело. После небольшого перерыва привез станок в новое место и попытался включить. Станок BZT работает от Mach3. Ось x нажимаю и в право и в лево едет в одну сторону. Такая же беда и с осью z. Одна ось y правильно двигается. Уже голову сломал. И пины выставлены,  и даже горячии клавиши посмотрел. Ничего не помогает. Кто сталкивался с подобной проблемой или знает что нужно сделать подскажите пожалуйста.

Опторазвязка скорее всего крякнула, либо не правильно подключено управление на самом драйвере.

0

3

Alex83 написал(а):

Уважаемы форумчане подскажите пожалуйста в чем может быть дело. После небольшого перерыва привез станок в новое место и попытался включить. Станок BZT работает от Mach3. Ось x нажимаю и в право и в лево едет в одну сторону. Такая же беда и с осью z. Одна ось y правильно двигается. Уже голову сломал. И пины выставлены,  и даже горячии клавиши посмотрел. Ничего не помогает. Кто сталкивался с подобной проблемой или знает что нужно сделать подскажите пожалуйста.

Добрый день. У меня была похожая проблема,  В результате выяснил что перебит один из проводов ведущих к движку!! прозвоните провода!!!!!

0

4

georg105 написал(а):

Добрый день. У меня была похожая проблема,  В результате выяснил что перебит один из проводов ведущих к движку!! прозвоните провода!!!!!

если перебит провод двигателя он крутить вообще не будет проблема в управлении.

0

5

stasblak написал(а):

Опторазвязка скорее всего крякнула, либо не правильно подключено управление на самом драйвере.

Можно по конкретнее что за опторазвязка. Я ничего не менял после последнего рабочего дня. Единственное при переезде был утерян провод LPT. И я в радиомагазине купил, он с двух сторон был одного выхода (то ли мама то ли папа, непомню) И я купил переходник. Может быть проблема в этом проводе или нет?

0

6

Подскажите пожалуйста а настройки в окне Выходные сигналы могут повлиять на мою ситуацию или они здесь не причем и только настройки пинов в окне Выходы двигателей играют роль?

0

7

Alex83 написал(а):

Можно по конкретнее что за опторазвязка. Я ничего не менял после последнего рабочего дня. Единственное при переезде был утерян провод LPT. И я в радиомагазине купил, он с двух сторон был одного выхода (то ли мама то ли папа, непомню) И я купил переходник. Может быть проблема в этом проводе или нет?

Скорее всего проблема в кабеле и переходнике.
Чтобы это проверить - стоит прозвонить линии отвечающие за проблемную ось.

0

8

Alex83 написал(а):

Можно по конкретнее что за опторазвязка. Я ничего не менял после последнего рабочего дня. Единственное при переезде был утерян провод LPT. И я в радиомагазине купил, он с двух сторон был одного выхода (то ли мама то ли папа, непомню) И я купил переходник. Может быть проблема в этом проводе или нет?

Михаил полностью прав, у вас проблема с ЛПТ кабелем, просто первый раз слышу про кабель с одинаковыми штекерами.

0

9

Alex83

Долго не мучайтесь! Проблема в кабеле идущего от драйвера к шаговику. Чтобы убетиться, попробуйте просто заменить один кабель на новый...

0

10

skedram написал(а):

Долго не мучайтесь! Проблема в кабеле идущего от драйвера к шаговику. Чтобы убетиться, попробуйте просто заменить один кабель на новый...

Если бы такое было - то мотор бы вообще не работал бы, а только жужжал на месте.
stasblak уже об этом написал.

0

11

skedram написал(а):

Alex83

Долго не мучайтесь! Проблема в кабеле идущего от драйвера к шаговику. Чтобы убетиться, попробуйте просто заменить один кабель на новый...

Я провода от драйвера к движку перекидывал на единственную рабочую ось. И x и z перекидывал, начинают нормально работать.

0

12

Подскажите пожалуйста а настройки в окне Выходные сигналы могут повлиять на мою ситуацию или они здесь не причем и только настройки пинов в окне Выходы двигателей играют роль?
Проблемно у нас в городе с проводом LPT. Придется заказывать через интернет. Дай Бог что бы действительно в нем дело было.
Я думаю или кабель или с драйверами что то случилось. На что еще думать я не знаю.
Завтра буду побывать опять разобраться. Всем спасибо за советы и за мнения.

0

13

проверьте провод направления DIR, возможно какой-то перебит или нет контакта. у меня проводок отошел от платы управления тоже самое было.

0

14

Кабель LPT вставьте плотнее и винтами затяните обязательно, были преценденты что без затяжки винтов контакт пропадал
Любым доступным(кроме клавиатуры)способом -например в MDI задайте движение по осям в + и в- если отработает верно то клавиатуру смените или мусор из нее вытряхните Это пара случаев из практики поиска неисправности станков.....
Со стороны наверно покажется что советы несколько туповаты,но именно эти "детские" болезни заставляли провести у неисправного станка некоторое количество времени в поисках неисправности...... Ну да ладно шутки в сторону-раз кабель LPT поменяли на новый то ему стоит уделить особое внимание, возможно что производитель кабеля на проводе экономит и не все жилы распаяны.

Отредактировано nikson (21-09-2013 23:52:21)

0

15

Alex83 написал(а):

Подскажите пожалуйста а настройки в окне Выходные сигналы могут повлиять на мою ситуацию или они здесь не причем и только настройки пинов в окне Выходы двигателей играют роль?


В данном случае - нет! Там только сигнал enable главное...

michael-yurov написал(а):

Если бы такое было - то мотор бы вообще не работал бы, а только жужжал на месте.


Было у меня в практике такое Михаил и не один раз... Двигатель вращался хаотично только в минус, и проблема была именно в кабеле. Такое бывает при длительном простое станка в плохих условиях. Видно кабель в месте изгиба от длительного простоя после запуска повреждается. Ну раз Alex83 пробовал перекинуть провода, то в его случае это не то...

Alex83
А ты не можешь прозвонить кабель LPT тестером?

0

16

Я так думаю проблема в неправильной распайке кабеля ЛПТ, просто на драйвер просто не подаётся сигнал ДИР, при этом двигатель просто вращается в одну сторону.

0

17

skedram написал(а):

Было у меня в практике такое Михаил и не один раз... Двигатель вращался хаотично только в минус, и проблема была именно в кабеле.

Если речь про шаговый двухфазный мотор, то при повреждении одного кабеля будет работать только одна обмотка, и работать он будет, как велосипед с одной педалью - если повезет и начнет крутиться - то не известно, в какую сторону, и крутящий момент будет мизерным и вращение сильно вибрирующим. Но мотор, если будет вращаться, то именно хаотично, а не в каком-то одном направлении. Да и вообще скорее всего просто на месте жужжать будет, а не вращаться.

0

18

99% кабель от компа к драйверу. либо плохо закреплён, либо пробит. желательно заменить и проблема исчезнет.

0

19

может подключили неправильно

0

20

Уважаемый, отпишись, помогла ли замена LPT-кабеля ? У меня происходит нечно подобное.

0

21

Спасибо всем за советы. Проблема решена. Нашел другой кабель LPT, подключил и все поехало как надо. Я честно говоря до обращения на форум на кабель даже и не думал. Еще раз всем большое спасибо.

0

22

Может быть кому-то пригодится. У меня была похожая проблема, не совсем такая, но ось X иногда ездила как положено, а иногда только в одну сторону. Замена LPT-кабеля не помогла. Помогла замена контроллера. Оплошал Пурелогиковский контроллер PLC330,
а на высоте оказался простой дешевый китайский контроллер, купленный на e-bay-е за 30 баксов. Станок сам собирал, поэтому грешил на все кроме пурелогиковского контроллера, они же говорили, что все у них проверяется и все очень замечательно.
Но это не совсем так. В общем два раза делал заказы в Purelogic - е и оба раза некачественный товар, выводы делаем сами.

0

23

Похожая проблемка.
Станок простоял неделю без работы. До этого работал как по маслу. В помещении делали ремонт и передвигали станок.
При включении загорелись зеленым на оси Y Limit Switch on - уже был такой вопрос у меня, и он решается переключением во вкладке I/O.
Переключил. Появилась интересная штука. Ось Z работает нормально. Шпиндель крутится на установленных оборотах, и перемещается ввверх и в низ. А вот остальные две
оси стали двигаться только в одну сторону. Нажимаешь на право, едет на право. нажимаешь налево, а едет опять на право! Все контакты перевоткнул, вроде не отходит ничего.
ЛПТ тоже снял и закрутил заново. Ничего не помогло - оси едут только в одну сторону. Прозванивать нечем.
Что это может быть?

0

24

ZANDERFISH написал(а):

Что это может быть?

Не переключаются команды DIR.
Если

ZANDERFISH написал(а):

Прозванивать нечем

Можете собрать пробник,например,один из них:http://se.uploads.ru/t/bKeQP.jpg
http://se.uploads.ru/t/q6Wrb.jpg
и произвести последовательный поиск,начиная с выхода LPT компьютера и до контроллера.Для сравнения можете использовать рабочий канал.При изменении направления движения сигнал меняет своё состояние на противоположное.Удобнее пробник с двумя светодиодами--один щуп сАдите на корпус(минус питания)и второй на провод/контакт сигнала DIR.Светодиод должен или загореться или потухнуть при смене направления.Исходное состояние зависит от того какой активный уровень у Вас выставлен в установках:http://se.uploads.ru/t/g0nVt.jpg

0

25

Я простой советский юзер, который миллион лет назад собирал радиоприемничек из наборов в магазине Пионер.
Т.е. познаний в области электротехники никаких!

0

26

В интернете можно найти Мультиметр Ресанта DT 830B  цена   171 р. Да и по местным ларькам/магазинам пробежаться не помешает, рублей 300 будет стоить. А если будет с пищалкой, то им можно будет не только сигналы проверить, но и удобно будет выставлять Z, прикупив пару крокодилов в придачу.

0

27

Только сегодня занимался подобной проблемой. У и Z нормально едут а Х живет своей жизнью. Пересмотрел все что можно в итоге прокинул новый кабель от драйвера к движку и все заработало.

0

28

Здравствуйте.
Та же проблема с Х.
Подключение по юсб.
Все было хорошо, но ось Х была наоборот.
В китайском мануале парочитал, чтоб перевернуть ось, надо поставить галочку дир лов активе. Я установил ее, направление поменялось, но движение в 1 сторону, снимаю, в другую, но только в одну.

0

29

Imobile написал(а):

Здравствуйте.
Та же проблема с Х.
Подключение по юсб.
Все было хорошо, но ось Х была наоборот.
В китайском мануале прочитал, чтоб перевернуть ось, надо поставить галочку дир лов активе. Я установил ее, направление поменялось, но движение в 1 сторону, снимаю, в другую, но только в одну.


Т.е. вы меняете "Дир Лоу Актив" и ось в реале едет в другую сторону?

Хм.... Если так, то это ж получается, что сигнал с выходного пина по факту до драйвера доходит!
Но - не изменяется от системы управления.

Что за плата у вас и как вы изменяли настройки?

0

30

Плата, китайская, что-то воде usb mach3 controller. Проблему решил, запустил под администратором мач3 и поставил дополнительно галку справа от дир(кажется степ)

0

31

Да у меня тоже пару раз было изза кабеля. Сгнил. В подвале где режу сыро и видимо вода попала в контакт - пошло электричество и отгнил через пол года.

0

32

Имеется похожая проблема.
Добавил 5-ый шаговик на поворотную ось.
От платы менял оси - все работает нормально.
Менял лтп кабель - непомогло.
Вражается только в одну сторону.
Менял в настойках вращение, всеравно вращается в туже сторону но с другой кнопки.
Что интересное, поменял местами пины, было 1 и 16 поставил 16 и 1, ночало вращаться с обоих кнопок но только в одну и ту же сторону.
Помогите, что не так?

Отредактировано ruf07 (13-12-2016 17:05:50)

0

33

За изменение направления отвечает сигнал DIR. Его ищите

0

34

Менял. Меняется кнопка а вращение в туже сторону. Категорически не хочет вращаться в дрегую сторону. Перепробовал кучу настроек этом окне

Отредактировано ruf07 (13-12-2016 20:03:35)

0

35

ruf07 написал(а):

Менял. Меняется кнопка а вращение в туже сторону. Категорически не хочет вращаться в дрегую сторону. Перепробовал кучу настроек этом окне


Вопрос не в кнопке.
Вопрос в физическом приходе сигнала ДИР на драйвер.

Либо сигнал ДИР туда не приходит, либо драйвер дефектный.

0

36

andyshcher64 написал(а):

Вопрос не в кнопке.
Вопрос в физическом приходе сигнала ДИР на драйвер.

Либо сигнал ДИР туда не приходит, либо драйвер дефектный.

Менял оси на плате, то есть двигетель и драйвер и блок питания работают.
Остается плату проверить.

0

37

Тоже была такая проблема стнок СМ-1500 плата NC-studio,  проблема была в сгоревшем концевом датчике, поменял с другой оси все прошло.

0

38

nevborisov26 написал(а):

Тоже была такая проблема стнок СМ-1500 плата NC-studio,  проблема была в сгоревшем концевом датчике, поменял с другой оси все прошло.

К плате кроме осей ничего не подключено

0

39

проблема решена.
Все провода и лтп прозвонил - все норм.
даже плату поменял -результат тотже.
решилось настройками. Было так:
http://s7.uploads.ru/t/TAC9s.jpg
с расстроенными чувствами пошел методом "тыка" и вот как заработало:
http://sh.uploads.ru/t/Otaxr.jpg

0

40

ruf07 написал(а):

вот как заработало:


Однако...

1. Получилось, как и говорили, сигнал ДИР не приходил
2. Вопрос в другом: а почему взяты такие настройки, что сигнал ДИР находится на пине 1, а не на пине 17?
Откуда взяты данные?

И да, что за плата у вас?

Отредактировано andyshcher64 (15-12-2016 06:56:02)

0

41

andyshcher64 написал(а):

Однако...

1. Получилось, как и говорили, сигнал ДИР не приходил
2. Вопрос в другом: а почему взяты такие настройки, что сигнал ДИР находится на пине 1, а не на пине 17?
Откуда взяты данные?

И да, что за плата у вас?

Отредактировано andyshcher64 (Сегодня 06:56:02)

так ведь на 17 пине и стоит.
В том то и дело что настройки подбирал от отчаянья методом тыка.
Плата 5-и осевая с полной опто развязкой
http://images.ua.prom.st/20018601_w640_h640_1.jpg

0

42

ruf07 написал(а):

подбирал от отчаянья методом тыка


Странно....
Зачем методом тыка-то?
Есть же мануал...

Как там было было написано?
1-й или 17-й ?

0

43

andyshcher64 написал(а):

Странно....
Зачем методом тыка-то?
Есть же мануал...

Как там было было написано?
1-й или 17-й ?

Получилось 16-й и 17-й
И работает

0


Вы здесь » Форум клана ЧПУшников » Станки с ЧПУ » По оси х едет только в одну сторону.