Форум клана ЧПУшников

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » Форум клана ЧПУшников » Станки с ЧПУ » плавный уход по оси х


плавный уход по оси х

Сообщений 1 страница 28 из 28

1

Всем добрый день. Возможно и не стоило создавать новую тему. Но я уже и здесь пересмотрел тему про возможный уход координат и на других форумах. Все что можно – поустранял, переделал.
Короче ситуация такая. Станок самодельный, идет плавный уход координат по х в минус. Причем я уже пробовал разные модели в арткаме делать, пробовал вначале в 12 арткаме. Потом вычитал, что арткам бывает глючный. Поставил 11. сделал ту же модель, косяк тот же. Все заземлено, кабели к шаговикам идут экранированные. К шпинделю пустил в металлорукаве. Плату спрятав в метал.корпус и заземлил. Станок заземлил. Короче голова кругом. Но насколько я понимаю – это не пропуск шагов. Просто какое –то плавное смещение.

p.s.  если не там создал тему – пусть модераторы меня поправят

0

2

забыл добавить. плата управления "красная", на 4 оси. на оси y стоит два шаговика.

0

3

Муфта на двигателе хорошо закреплена?

0

4

TON29 написал(а):

Муфта на двигателе хорошо закреплена?

мы ее сажали на жидкий фум, плюс болты. но все-равно  пошел проверил - держится мертво

0

5

если уход плавный, то смотри гайки, муфты и тп.

а вообще в каких пределах?

моторчики на какой момент, ток на сколько выставлен, какое напряжеине? какие подачи и ускорение на шд? Как у меня, так ускорение влияет сильно на пропуски, можно поставить меньше и прибавлять постепенно.   если плавный уход, то должно быть что, то типо /_/   когда режем |_|    а вот если пропуски, то будет ступенька.

0

6

ток максимальный, питание 36 вольт.


http://s8.uploads.ru/t/ZYS9i.jpg
вот начинал одну и ту же заготовку в разных режимах. все время уходит по оси х. плавно. я тоже думаю, что это не пропуски. а какие скоростя и ускорения - посмотрю завтра на работе. по памяти не помню.скажите, может ли влиять скорость выставленная в арткаме в параметрах инструмента? или одно ко второму не имеет никакого отношения?

Отредактировано racon75 (22-06-2016 18:26:35)

0

7

скорость в арткаме задает подачу для инструмента. С такой максимальной резать и будет, если она не превышает максималку, выставленную для осей в Маче. У меня так уходило по Зет от нехватки момента на движке, из-за инерции оси при действующей силе тяжести. Но тут почему именно в одну сторону уезжает - сказать сложно. Гайка бы уже выскочить должна по логике за такое время.

Поменяйте Х местами с У  к примеру, так чисто контроллер проверить.

А звуков на пропуски похожих не издает?

0

8

achuser написал(а):

У меня так уходило по Зет от нехватки момента на движке

Поменяйте Х местами с У  к примеру, так чисто контроллер проверить.

А звуков на пропуски похожих не издает?


пробовал поднимать ноль на 8 мм при глубине обработки 9мм. т.е. фреза врезалась только на один мм. тоже уходит. т.е. должно хватать силы. вот местами поменять идея была. наверное завтра буду пробовать. правда еще есть сомнения по поводу самого мача. может он глючный? поставить может другую версию?

0

9

Может все-таки тока двигателю не хватает. Если уставки по X и Y одинаковые, то может действительно поменять местами, если все равно по тому же движку будет убегать то скорее всего проблема в движке.

0

10

поменял местами ось х и y. теперь  на х у меня два шаговика. запустил вхолостую, над заготовкой, без вкл. шпинделя  - вроде пошло все, ну чтобы проверить направление. остановил, выставал ноль, запувкаю.......а вместо того чтобы идти строго по х, начало резать и по х и по y под углом градусов 30.  запустил со шпинделем, но над заготовкой - снова пошло хорошо. может это шпиндель дает наводки? хотя сам шпиндель заземлил, блок тоже, а провод идет в заземленном металорукаве.

0

11

может и рано радуюсь. но кажется нашел причину. все время у меня стояла одна и таже сферическая фреза. она была старая, пробовать на новой не хотел. но после того как надало уводить под 30 градусов, я понял, что что-то не так. решил поменять фрезу. и о чудо......сейчас поставил оси как обычно, запустил ту же модель. пока полет нормальный. а там увидим.

0

12

Аналогичная проблема... Х так же плавно уходит в минус, только еще и Z, так же плавно, сползает вниз - при фрезеровании рельефа. Станок самодельный - поле 1000х1000мм, по Х и Y передача - зубчатый ремень/шестерня, по Z - винт трапеция/гайка (капролон). Менял дробление шага и ток на драйверах - не помогло. Проверил механику по Z - было подклинивание подшипников, которые центрируют перемещение площадки, на которой закреплен шпиндель... отрегулировал люфт - сползание по Z стало меньше, но не устранилось. Пробовал разные настройки скорость/ускорение - в Mach... Результат один - из круга вытягивает овал с плавным заглублением... При возвращении в ноль фреза останавливается левее и ниже нулевой точки. В голове уже каша от прочитанных советов, но надежда на освоение станка еще теплится, буду пробовать регулировать портал и "играться" с настройками и заменой осей. По результатам отпишусь

0

13

Прошу - не расценивать как флуд. Просто сочинил о наболевшем:

Из жизни выпал – со станком…
Чуть рассветет – к нему бегом
Готов всю ночь фрезеровать!
Но надо же когда-то спать…

А вышел тут такой облом
По «Z» подняться ему влом
Рельеф хочу фрезеровать
«Z» начинает вниз сползать

Я очень сильно негодую
И с матом, дальше фрезерую…
А лучше б не фрезеровал –
Из круга вытянул овал…

Значит уходит «Х» - зараза!
Деталь запарывал 3 раза!
Уходит в минус он и всё!
Что делать, братцы, Ё-моё!?

Уже заходит ум за разум –
Как победить эту заразу!?
Иль ШД тока не хватает?
Иль драйвер что-то там лажает?

Уходит ноль в итоге очень
Станок меня доканать хочет!
И вот на форуме я днями
Сижу – советуюсь с людЯми

Что делать? Дайте мне совет -
Как мне фрезеровать без бед?
Как со станком мне совладать?
Как «X» и «Z» мне обуздать?

+1

14

По зет проблема простая - не хватает момента из-за инерции, ибо сила тяжести вниз тянет шпиндель. Ставить пружину-подтяжку, либо блок с роликами если большой станок, либо ставить более мощный ШД.

А вот все уползания по другим осям - либо плохо что-то закрелено, либо фиг знает что.

0

15

achuser написал(а):

По зет проблема простая - не хватает момента из-за инерции, ибо сила тяжести вниз тянет шпиндель. Ставить пружину-подтяжку, либо блок с роликами если большой станок, либо ставить более мощный ШД.

А вот все уползания по другим осям - либо плохо что-то закрелено, либо фиг знает что.

Вчера поставил пружину - сильной разницы не заметил ((( 
Стоит шаговикPL86H75-D14, по характеристикам от Purelogic - момент удержания 46кг х см. Вес шпинделя (GDZ-80-1500вт, с жидкостным охлаждением) 4,2кг + охлаждающая жидкость, примерно 1кг (по справочнику Потолково - Фанаревского) + вес самой каретки, примерно, 2-3кг. ИТОГО: мотор тягает 7-8кг Вопрос: такая масса - повод для установки пружины, при таком ШД?

0

16

Проблемы с уходом Z наблюдаются только при фрезеровки рельефа. При фрезеровки ровных площадок Z остается на месте, но Х, постепенно сползает влево. Стратегия обработки - растр. Если фрезеровать квадрат, по контуру, разница диагоналей есть, но она небольшая. По моим соображениям - уход по Х это накапливаемая погрешность, но как её устранить? Изделие получается таким \_\ Выравнивание, даже заметный перекос портала результатов не дали... Продолжу свои мытарства на выходных...

0

17

какой контроллер и БП? Если китаец, то его уже мало для такого мотора, мощность мотора с запасом на 46 кг. Мотор греется при работе или холодный?

0

18

проблема стара как мир- основа проблемы- желание поставить скорости и ускорения побольше- а у шаговика момент максимальный как раз при минимальных скоростях
причин ухода может быть несколько- первая- переразгон- попробуйте в маче установить маленькое значение ускорения- ну например 25 и проверить на накопление ошибки
вторая причина - высокая скорость- рецепт тот же-от малой скорости до срыва-всегда оставляйте себе запас процентов 20 от той скорости- на которой мотор перестает крутить ось
третья причина - пережаты гайки- попробуйте пощупать ходовой винт после 15-20 минут работы- если вал нагревается- то либо регулируйте натяг либо меняйте смазку- слишком велико трение и как следствие при перегреве гайки клинит- кстати буквально вчера сам нарвался- перегрелись гайки после 5 часов работы- хотелось побыстрее- поставил 3800 мм мин режим резки- а в гараже африка плюс 37 вот и перегрелись гайки как следствие мотор ушел в срыв...
и еще одна причина- может  причина?- может опторазвязка на высоких скоростях может просто терять уровень сигнала- но тогда потеря координат идет как влево так и вправо и отследить можно только с осциллографом----
уф много слов- надеюсь с их помощью попробуете решить вашу проблему
для начала откиньте мотор и вручную погоняйте ваши оси- убедитесь что не слишком туго крутятся.... а потом пошагово увеличивайте настройки в маче- должно помочь....

0

19

все бы хорошо, но вот кроме описанной проблемы с нагревом гаек - остальное логике не поддается. Т.к. у меня резка выставлена уже с занижением куда большем, чем 20%. А когда будет пропуск - не предугодать. Поочередно грызут мозг то Х, то Z.

Вот вчера Х ушла, сегодня после 2 часов 20 минут Z нырнула вниз на сантиметр, прорезав стол.

При том, что ускорение даже меньше, чем вчера для нее стояло.

Кабель от Х сегодня в экран надел, гайку подтянул, думал с ней проблемы и будут основные, но нет, откатала (тьфу,тьфу,тьфу). Зет вчера тоже в экран засунул. но вот один серьезный пропуск и все напрасно, ладно бы вверх ушла, можно было бы дорезать, а так на выброс.

0

20

У меня было точно так-же, уходил Х влево! Только у меня интерфейсная плата BL-MACH-V1.1.
Оказалось что криворукие китайцы, спаяли вместе два контакта, там где сам выход ЛТП впаян в плату! Розпаял эти контакты, и все пучком!!!

0

21

Чаще всего причиной смещения является плохой контакт одного из соединений по электронике. Я с этим очень долго мучался, сам не один станок собрал. На самоделках рекомендую концы входящие в платы и др. пропаивать на 3-5 мм.

0

22

Илья Фоменко написал(а):

Чаще всего причиной смещения является плохой контакт одного из соединений по электронике. Я с этим очень долго мучался, сам не один станок собрал. На самоделках рекомендую концы входящие в платы и др. пропаивать на 3-5 мм.

Так и есть! В моей самоделке досмотрел, что человек, который собирал мне станок перепутал провода в клеммах драйвера для оси Х (там где А-, А+, В-, В+). Поменял местами провода - поставил так же как на остальных 2-х драйверах, протянул все зажимные винты на контактах драйверов и ВУАЛЯ!!! Ось Х перестала уходить влево!!!  Пришлось только инвертировать ось Х - в настройках Mach, а то стала бежать не туда. Возможно это совпадение, но до этого ничего не помогало - Х тянуло влево.

0

23

achuser написал(а):

какой контроллер и БП? Если китаец, то его уже мало для такого мотора, мощность мотора с запасом на 46 кг. Мотор греется при работе или холодный?

Контроллер гляну - напишу, БП, по моему на 36В, но лучше уточню. Мотор греется, но руку держать можно, полагаю это нормальная рабочая температура, а вот драйвера греются сильно - можно обжечься об радиатор ((( Ток убавил до 3,3А
Про Х написал выше.  С Уходом вниз по Z проблема осталась ((( Проводил "Дрыготест", рекомендованный в одной из здешних тем, для Z. При дрыгании +10 0 -10, на F 2500  15раз, фреза остановилась ниже нулевой точки на 0,5мм Вот и накапливается постепенный уход... Грешу на механику, возможно подклинивание из-за особенности самодельной каретки. Буду разбираться...

0

24

если двиг холодный после 30 минут резки, а контроллер горячий. то это говорит о том, что ток на ШД идет посредственный для его возможностей, а контроллер слабоват.

Ставьте кулера на контроллеры. Скорей всего, если уход по Зет всегда вниз - не хватает моменты ШД. Нужно поставить пружину на ось- подтяжку. если уменьшится или исчезнет проблема, то дело в этом.

0

25

Рано обрадовался (((

0

26

http://s4.uploads.ru/t/SahkI.jpg
http://s9.uploads.ru/t/j3LdD.jpg
Так же плавно уходит по Х и ползет вниз по Z....

Отредактировано Mihas1000 (14-04-2017 10:07:23)

0

27

http://sd.uploads.ru/t/cv9Po.jpg

По всем осям стоят такие движки

0

28

Здравствуйте, недавно собрал станок. Однако при работе обнаружился следующий косяк: при фрезеровке вдоль оси y(самая длинная) ноль с каждым проходом смещается в отрицательном направлении. При фрезеровке вдоль оси x в один проход проблема исчезает. Но при обработке в несколько проходов появляется "лестница" в стороне, противоположной нулевой точке. По окончанию обработки ноль смещается только по оси y, по остальным осям не изменяется. Ошибка возникла сразу после сборки. Перебрал уже всё, что находил ранее, а именно: механику проверил; менял режимы работы программ; перебрасывал ось на другой выход; сменил Mach3 на Puremotion; оптимизировал комп; менял скорости и ускорения. Все вышеупомянутые методы не принесли результатов вообще. Что касается деталей: драйвер-PLC545, контроллер-PLCM-E1b, двигатели - PL57HD110-d8. Что может быть не так?

0


Вы здесь » Форум клана ЧПУшников » Станки с ЧПУ » плавный уход по оси х