Форум клана ЧПУшников

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » Форум клана ЧПУшников » Станки с ЧПУ » Собираем станок плазменной резки


Собираем станок плазменной резки

Сообщений 1 страница 43 из 43

1

Приветствую всех участников данного форума!
В этой теме мы будем собирать станок плазменной резки своими, а если точнее, моими руками :)
Немного предыстории: выбирая двери в новопостроенный дом я пошёл выбирать двери, среди однотипных штамповок я увидел двери с очень красивым накладным декором, которые мне сразу понравились, но когда я узнал цену, мне пришла в голову мысль подобный декор вырезать самому. Немного поискав в интернете я нашёл подходящий ЧПУ станок по приемлемой цене.

http://sh.uploads.ru/t/LoaqN.jpg
http://sg.uploads.ru/t/IkLKB.jpg

Поработав на нём некоторое время я понял, что для изготовления подавляющего числа деталей в отрасли моей непосредственной деятельности, необходимо не столько фрезеровать, сколько вырезать. Посмотрев цены на станки плазменной резки мне показалась неплохой идея создания его своими руками.
Немного прикинув решил не мелочиться и сразу сделать стол 3х1,5м. Вот что получилось:

http://sg.uploads.ru/t/Zhjrf.jpg
http://sh.uploads.ru/t/qBOm3.jpg

Заказал направляющие sbr-16 и прямозубые рейки на обе стороны по оси Y (по длинне), на ось Х на портал тоже 2 направляющих sbr-16 и прямозубую рейку.
В качестве шаговых двигателей заказал 3 шт. nema 23 (в комплекте с драйверами, контроллером и блоком питания), 2 штуки на ось Y и один на X (кажется я прогадал по мощности):

http://sg.uploads.ru/v0KpI.jpg

Привод с ШД на рейку думаю сделать прямой через шестеренку.
Механика уже пришла, теперь настало время сделать портал...

Вот на данном этапе я сейчас нахожусь. Буду рад любому совету и не откажусь от помощи, собираю станок впервые. Спасибо за внимание :)

+1

2

Вашим движкам нужно будет большое рабочее напряжение. Т.к. большая индуктивность. Скорость большую не получите. Если есть возможность поменяйте. Да и лишняя мощность не помешает. Закажите длинной 115мм.

+1

3

Geolog написал(а):

(кажется я прогадал по мощности)

Не то слово прогадали, такого типа двигатель даже на плазме таких габаритов можно поставить разве, что на ось Z, пока есть возможность поменяйте как вам выше сказали на более мощные например 115 с таким же фланцем, но опять же при таких габаритах вам желательней ставить редукторы хотя бы 1/2.
Вообще в идеале ставить двигателя с минимальным усилием от 46 кг/см
Прочитав выше - 1,5*3 м это размер вашей станины (реальный) или желаемое рабочее поле? Конструкцию рамы на сколько вижу подсмотрели на сайте делитант, ПО-МО.

+1

4

3 на 1.5 это габариты стола на данный момент, рабочее поле будет немного поменьше ввиду установки направляющих.

PL86H75-D14
86x75мм, 46 кг.см, вал 14мм, ток 3.5А, шаг 1.8°

+

Драйвер шагового двигателя 40В/4.0А/200кГц на микросхеме THB6064. Деление шага двигателя 2/8/10/16/20/32/40/64. Оптоизолированные входы управления STEP, DIR, ENABLE. Защита от КЗ обмоток ШД, от обратной ЭДС ШД, от перегрева, режим удержания ротора ШД.

Такие с прямой передачей (напрямую шестеренка) пойдёт? Контроллер PLC5x запитаю проверенным способом - блоком питания от компьютера. Посоветуете, что ещё сразу заказать

реклама под кат

у чистой логики (purelogic)

?

Отредактировано Geolog (10-04-2015 06:38:39)

0

5

Geolog написал(а):

3 на 1.5 это габариты стола на данный момент, рабочее поле будет немного поменьше ввиду установки направляющих.


Такие с прямой передачей (напрямую шестеренка) пойдёт? Контроллер PLC5x запитаю проверенным способом - блоком питания от компьютера. Посоветуете, что ещё сразу заказать

?

Отредактировано Geolog (Сегодня 06:38:39)


Двигателя достаточно, драйвер откровенная гадость, шестерни ссылки нет, но прямая передача на рейке это откровенная лажа. На ремне и старых двигателей хватило бы

0

6

uxtbl написал(а):

Двигателя достаточно, драйвер откровенная гадость, шестерни ссылки нет, но прямая передача на рейке это откровенная лажа. На ремне и старых двигателей хватило бы

На ремне разницу в шестернях какую делать? И потом шаг выставить будет не проблематично?
Слабенькие моторы я уже заказал из Китая, не хотелось бы ещё покупать. Они кстати напрямую к контроллеру идут. Чем чревата экономия на драйверах?

Вот заказ ШД

http://www.aliexpress.com/item/3Axis-Nema-23-Stepper-Motor-287oz-in-Driver-CNC-KIT-ROUTER/1856591293.html

0

7

Драйвер на каждый ШД хорош тем что можно настроить под конкретный двиг. (PID регулятор) что-бы режим работы ШД близок к идеалу (перерегулирование, время регулирования , затухание и т.п.) что позволит добить ся высоких скоростей и ускорений без срывов
Эти драйверы не прощают ошибок. Если хотя бы один провод двигателя замкнется на землю - вылетают со спецэффектами. Это происходит как раз потому, что токоизмерительные резисторы включены в разрыв земли, и любой ток, не проходящий через этот резистор не учитывается, что приводит к моментальному выходу из строя верхних транзисторов.

Также если перепутать провода при подключении, также недопустимы межфазные замыкания. При этом ток через транзистор обмотки А потечет через резистор обмотки В, что также приведет к выгоранию.

Очень критичен порядок подачи питающих напряжений — сначала низкое (5 вольт на питание логики) и только потом — высокое (на питание двигателей). На последних платах с этим драйвером я даже заметил отдельные стабилизаторы 5вольт для каждого драйвера, что практически исключает отсутствие низкого напряжения при начале работы.

Включать драйвера без подключения двигателя можно, проблем не будет.

Крутить двигатели при отсутствии питания драйверов — запрещено. Двигатели вполне могут создать напряжение выше допустимых 40 вольт. При нормальной работе напряжение самоиндукции утилизируется источником питания или демпферными схемами. При отключенном источнике питания — только пробитыми транзисторами.
Поэтому дозакажите хотя бы прозапас TB6560 пару тройку шт.
А то что портал на зубчатой рейке(ремне), забылись  без питания толкнули,прокатили и усё,  привод на винтах в этом отношении имеет ряд преимуществ, НО слишком большие габариты Вашего станка не позваляет применить виты, вернее можно по Х

0

8

Geolog, у вас интересный способ постройки станка, сначало вы приобрели почти все комплектующие, сварили раму и только после обращаетесь на форум с вопросами, да ладнл бог с ним.
Про плату с драверами, написаное выше, полная правда, для начальных экспириментов и мук подойдёт.
Двигателя которые вы выбрали с 86 фланцем, в идеале питать нужно от 60 до 75 вольт, что бы получить максимальный момент и скорости которые они могут выдать, но ваша многоосевая плата может питаться максимум 40 вольтами, это уже минус.
Можно было собрать портал и на двигателях которые вы заказали из китая, но не на зубчатой передаче, а на ремённой, но вы уже приобрели рейки, так что прийдётся работать с ними, редукция на данных приводах, как я писал выше хотя бы 1/2, и в основном это не для поднятия крутящего момента, а для плавности хода, что бы сгладить шаги двигателя передаваемые на шестерню.
Мощность двигателей, не последний параметр на плазменной резке, так как станок работает в основном на больших ускорениях с постояной скоростью, что по прямой, что по дугам, что на углах, иначе рез у вас будет получаться отвратительный.

На данный момент вам надо поставить себе задачу, сконструировать консоль с минимальным весом, но достаточно жёсткую, иначе устанете бороться потерей прямого угла во время работы.

Отредактировано Flint2015 (10-04-2015 16:17:35)

0

9

После отдыха на Андаманском побережье, приехав домой, вдруг обнаружил, что станок сам не собрался o.O
Ну чтож... Видимо придется доделывать его своими ручками. И так!
Стол я уже показывал, но теперь я его оборудовал порталом на портале на стол. Выглядит у меня это следующим образом:
http://sg.uploads.ru/t/68bFs.jpg
http://sg.uploads.ru/t/VZW8e.jpg
http://sh.uploads.ru/t/9tFpq.jpg
http://sg.uploads.ru/t/tHhOA.jpg
http://sh.uploads.ru/t/5wh0r.jpg

Боковые двигатели Нема 34 по 56 кг*см, передачи как видите реечные. Всё собрал, теперь вопрос остался за малым - заставить это всё работать. Я думал всё будет легко и непринужденно - соберу по схеме, подключу к компу, проверю, соберу спец комп в стойку... В общем стадию "соберу по схеме" я вроде выполнил, а вот "подключу к компу" оказалось не так просто. Сперва возник вполне резонный ньюанс с отсутствием LPT порта в материнке моего компутера. Фигня война - в ближайшем магазине покупаем PCI контроллер. Вставляю в свой комп - драйверов для win7x64 нет. Окей, есть другой комп, там ХР, вставляю туда, устанавливаю драйвера - порт в работе. Далее собираем по схеме контроллер - драйвер - ШД:
http://sh.uploads.ru/t/tVwAZ.jpg
http://sh.uploads.ru/t/bDtOY.jpg
http://sg.uploads.ru/t/RMX0Y.jpg

Вроде всё по схеме, подключил ось Х, в мач3 включаю драйвертест - показывает всё как надо:
http://sg.uploads.ru/t/bzWq7.jpg

В маче выставил порт, частоту.. По инструкции. Не реагирует.
Как заставить эту шайтан-машину подчиниться моей воле?! Помогите, о мудрейшие!

0

10

1. Посмотрите, приходят ли импульсы на вход СТЕП у драйверов. Тема уже старая и замусоленная до дыр.
2. Убедитесь, что сигнал Enable не блокирует драйверы. (по умолчанию, будучи неподключенным, он разрешает работу)

Пока наиболее вероятное - некорректная настройка МАЧа.

0

11

andyshcher64 написал(а):

1. Посмотрите, приходят ли импульсы на вход СТЕП у драйверов. Тема уже старая и замусоленная до дыр.
2. Убедитесь, что сигнал Enable не блокирует драйверы. (по умолчанию, будучи неподключенным, он разрешает работу)

Пока наиболее вероятное - некорректная настройка МАЧа.


http://sh.uploads.ru/t/VltYy.jpg
http://sh.uploads.ru/t/D8ihO.jpg
http://sg.uploads.ru/t/y6zI5.jpg
http://sh.uploads.ru/t/SeblU.jpg
http://sg.uploads.ru/t/GB73Q.jpg
http://sg.uploads.ru/t/c9iQ5.jpg
http://sg.uploads.ru/t/5JTWV.jpg

0

12

Все это гуд, но применимо ТОЛЬКО К ВАШЕЙ коммутационной плате.
(В смысле, вы эти скриншоты привели, но откуда мне знать, правильно ли это?).

Причем плата должна быть присоединена к драйверам правильно (полярность сигналов).

Уберите пока из настроек все ограничения по осям, дабы не мешать самому себе.
1. Убедитесь, что сигнал Enable не запирает драйверы.
2. Настраивайте сначала ОДНУ ось.
3. Убедитесь, что на вход СТЕП приходят импульсы. ДИР пока не так важен, ибо ось хоть куда-нибудь, но должна ехать.

Отредактировано andyshcher64 (23-06-2015 14:00:18)

0

13

Geolog

Последний скрин с настройкой ЛПТ порта.... 0х378 - почти уверен что указан не верный адрес порта.

0

14

Советую Вам сразу прикинуть, как вы подружите станок с системой корректировки высоты горелки по напряжению (THC). Без этой системы станок плазменной резки - груда бесполезного железа. Плюс обязательна система вытяжки из стола (желательно посекционно), иначе задохнётесь в первую же минуту работы

0

15

skedram написал(а):

Geolog

Последний скрин с настройкой ЛПТ порта.... 0х378 - почти уверен что указан не верный адрес порта.

http://sg.uploads.ru/R92Vf.jpg

0

16

andyshcher64 написал(а):

Все это гуд, но применимо ТОЛЬКО К ВАШЕЙ коммутационной плате.
(В смысле, вы эти скриншоты привели, но откуда мне знать, правильно ли это?).

Причем плата должна быть присоединена к драйверам правильно (полярность сигналов).

Уберите пока из настроек все ограничения по осям, дабы не мешать самому себе.
1. Убедитесь, что сигнал Enable не запирает драйверы.
2. Настраивайте сначала ОДНУ ось.
3. Убедитесь, что на вход СТЕП приходят импульсы. ДИР пока не так важен, ибо ось хоть куда-нибудь, но должна ехать.

Отредактировано andyshcher64 (Вчера 17:00:18)

Пробовал осциллографом относительно COM порта - тишина.... Сигнал enable в маче пробовал отключать - безрезультатно. Я и пытаюсь шевелить хотя бы одну ось  :dontknow:

0

17

Geolog написал(а):

В маче выставил порт, частоту.. По инструкции. Не реагирует.
Как заставить эту шайтан-машину подчиниться моей воле?! Помогите, о мудрейшие!

http://sh.uploads.ru/t/wefbr.jpg
Смотрю на ваше подключение, и не могу понять как у вас оно устроенно, смотрим от платы распределения выходят три толстых провода - степ, дир, и энейбл , а где +? я например вижу отходящие от драйвера 3 штуки тонких провода в сторону распределяющей платы.
Вот обьсните или нарисуйте, как у вас произведено подключение?
Если можно, дайте ссылку на плату опторазвязки.

Отредактировано Flint2015 (24-06-2015 17:01:29)

0

18

Flint2015 написал(а):

Смотрю на ваше подключение, и не могу понять как у вас оно устроенно, смотрим от платы распределения выходят три толстых провода - степ, дир, и энейбл , а где +? я например вижу отходящие от драйвера 3 штуки тонких провода в сторону распределяющей платы.
Вот обьсните или нарисуйте, как у вас произведено подключение?
Если можно, дайте ссылку на плату опторазвязки.

Отредактировано Flint2015 (Вчера 20:01:29)

Плата опторазвязки

http://duxe.ru/load/br_lpt.pdf

3 тонких провода идут на СОМ на плате согласно схеме.
На самом деле я очень лопухнулся, не заметив на этом компе родной LPT выход от материнки, и пытался работать через другой порт  :dontknow:  Но теперь у меня почему то драйвер не хочет включаться. Не горит зеленая лампочка на нем. При перезагрузке компа что то щелкает и он загорается зеленым, но при загрузке системы опять что то щелкает, и он вырубается  :mad:
Прозвонил - напряжение между СОМ и EN- 4.34 вольта, на остальных (степ и дир) пусто.

Отредактировано Geolog (25-06-2015 08:53:26)

0

19

Geolog написал(а):

При перезагрузке компа что то щелкает и он загорается зеленым, но при загрузке системы опять что то щелкает, и он вырубается  :mad:
Прозвонил - напряжение между СОМ и EN- 4.34 вольта, на остальных (степ и дир) пусто.


Щелкает на плате реле.

В настройках отключите реакцию на все сигналы Limit Switch.

Отключите (временно) провод EТ прямо на колодке драйвера.
Заизолируйте его.
Посмотрите, будет ли драйвер выпадать в ошибку (гореть красным).

+1

20

andyshcher64 написал(а):

Щелкает на плате реле.

В настройках отключите реакцию на все сигналы Limit Switch.

Отключите (временно) провод EТ прямо на колодке драйвера.
Заизолируйте его.
Посмотрите, будет ли драйвер выпадать в ошибку (гореть красным).

Пробовал на включенном отключать EN- и EN+ - ничего не загорается. Вырвал провод EN- и перезагрузил комп, до загрузки системы без провода EN- горела зеленая лампочка...

Если в диспетчере устройств на LPT порту обновить конфигурацию оборудования то на секунду загорается зеленая лампочка и он щелкает, а потом опять гаснет и молчит.

Отредактировано Geolog (25-06-2015 11:56:30)

0

21

Попробуйте оторвать ВСЮ сигнальную колодку от драйвера.
(Это колодка с сигналами СТЕП, ДИР, Енэйбл)

Потом подайте питание на драйвер.
Когда на нем загорится красная лампочка?
Какой драйвер у вас?

0

22

andyshcher64 написал(а):

Попробуйте оторвать ВСЮ сигнальную колодку от драйвера.
(Это колодка с сигналами СТЕП, ДИР, Енэйбл)

Потом подайте питание на драйвер.
Когда на нем загорится красная лампочка?
Какой драйвер у вас?

Подал без колодки, проверил - 24В. Красная не горит. Драйвер Microstep Driver FMD2440A

Если отключить LPT порт в диспетчере устройств и перезагрузить комп - горит зеленая лампочка, стоит порт включить - всё гаснет.

Отредактировано Geolog (25-06-2015 14:14:29)

0

23

У вас питание коммутационной платы и драйвера от разных источников питания выполнено?

И еще: нарисуйте хоть от руки, как вы соединили провода от коммутационной платы к драйверу.

+1

24

andyshcher64 написал(а):

У вас питание коммутационной платы и драйвера от разных источников питания выполнено?

И еще: нарисуйте хоть от руки, как вы соединили провода от коммутационной платы к драйверу.

http://sg.uploads.ru/t/M7LiY.jpg

LPT порт использую родной от материнки, если он подключается к драйверу, то драйвер гаснет. Попробую с платой другой завтра, думаю схватится  :dontknow:

Отредактировано Geolog (25-06-2015 18:49:57)

0

25

Geolog написал(а):

LPT порт использую родной от материнки, если он подключается к драйверу, то драйвер гаснет. Попробую с платой другой завтра, думаю схватится 

Отредактировано Geolog (Сегодня 22:49:57)

"Всё элементарно Ватсон" если посмотреть на вашу схему то у вас подключение с общим плюсом, а компьтера плюс идёт на пины, а общим является минус, вот поэтому у вас драйвер и гаснет.
Возможно что у вас напутано и с платой.
Ещё раз попросим, либо ссылку на плату опторазвязки либо название, тогда вопрос легче будет решить.

Отредактировано Flint2015 (25-06-2015 19:14:29)

0

26

Flint2015 написал(а):

компьтера плюс идёт на пины, а общим является минус, вот поэтому у вас драйвер и гаснет.


Тут вот в чем дело.
То, что выходит с коммутационной платы - это идет не прямо с пинов.
На коммутационной плате стоят еще буферы (или шинные формирователи).

Под плюсом и минусом общим на выходе коммутационной платы подразумевается как провод COM нужно прицепить к плюсам (или минусам) оптопар.
В данном случае COM идет на плюсы сведодиодов, а минуса светодиодов, соответственно, посредством буферных усилителей замыкаются на землю.

И как бы оно не было.
Драйвер ...ээээ.. не должен бы в аварию уходить при подаче на него сигналов.
Странно это.

Geolog

Подключение, судя по картинке, верное.
Попробуйте подключать сигнальные концы к драйверу по одному.
Сперва только один СОМ.
Потом СТЕП.
Потом ДИР.

Начиная с какого провода драйвер вывалится в осадок?

0

27

Не в то русло плывём, товарищи. До загрузки системы всё работает! И двигатель блокируется, и драйвер зеленым горит. Когда подгружается операционная система Windows XP на LPT порт подается сигнал, который выключает драйвер. Проблема в LPT порте и настройках его системных. Родная материнская плата с разъемом. Есть идеи?

0

28

Geolog написал(а):

подается сигнал, который выключает драйвер

Рассуждаем здраво.
Как порт может воздействовать на драйвер?
Есть только 3 логических входа.
EN, DIR, STEP
Все!
Больше никак!

Заблокировать, но не выключить, драйвер можно с помощью сигнала Enable.
Вполне возможно, что красная лампочка как раз и говорит, что получен запрещающий сигнал ENABLE.

Больше никак на драйвер не подействовать.
(если только подавать на него СТЕП и ДИР и заставлять крутить движок)

Либо вы не так объясняете, либо вас не так понимают.

Либо у вас перепутаны надписи назначений логических входов. На самом драйвере.
На части драйверов пара сигнальная EN расположена ближе к краю, а бывает, что и ближе к центру.

Для этого я вам и предлагал проводки по одному цеплять.
Попробуйте действия из поста 26.
Проблема где-то совсем рядом.
думаю, если бы до вас добраться физически, решили бы уже вашу проблему, посмеялись, да разошлись.

0

29

Geolog

Хочу уточнить, какой Виндовс все таки, случайно не 64бита? Мне странно то, что адрес порта 0х378 - по умолчанию родного порта. Для PCI должен был стоять другой...

0

30

Windows XP sp3 32 бита, напряжение на EN есть, когда драйвер гаснет. Обращаю Ваше внимание, что драйвер просто гаснет, ни красная ни зеленая лампочки не горят. Зато видно внутренний светодиод, он горит от EN. Там же, насколько я понял, светодиодные контакты с фотоэлементом в последовательной схеме. Следовательно если отключить любой из элементов - работать не будет. Я подозреваю, что LPT на том компе заточили под Topcon'овские приборы... Я уже драйвер на LPT удалял, заново ставил. При чем если его отключить - драйвер не отключается, винда грузится, вроде всё ок, НО как только подключить порт LPT - драйвер тут же гаснет. Жмешь на кнопку в диспетчере устройств "Обновить конфигурацию устройств" - зеленая лампочка загорится на секунду и гаснет. Благо у меня есть запас компов, сейчас на третьем попробую протестить  :dontknow:

На другом компьютере отсутствовал LPT порт, вставил плату PCI с портом, включил, запустил. Только поставил драйвера на плату с LPT - драйвер ШД сразу потух...

Отредактировано Geolog (26-06-2015 08:52:35)

0

31

andyshcher64 написал(а):

Подключение, судя по картинке, верное.
Попробуйте подключать сигнальные концы к драйверу по одному.
Сперва только один СОМ.
Потом СТЕП.
Потом ДИР.

Начиная с какого провода драйвер вывалится в осадок?


Вопрос - тест начинать как? Запустить без контактов между драйвером и контроллером, или оставить сперва контакт от всех плюсов драйвера к порту СОМ?
Чтобы горела зеленая лампочка на драйвере, нужно чтобы порт LPT на компьютере не функционировал. Т.е. запустить компьютер с отключенным портом. Вот я его запустил, от контроллера отцеплю СП, ДИР, ЕН, оставлю один контакт СОМ с SP+ DIR+ EN+. Так?

0

32

С полностью отцепленной сигнальной фишкой у вас уже опыт был.
Так?

Сейчас:
1 Оставьте прицепленным только провод СОМ.
Дальше поиграйте с портом.
Будет эффект?

2. Далее прицепите к фишке провод СТЕП.
Снова поиграйте с портом.
Будет эффект?

И т.д.

На какой стадии обнаруживается "Упппсссс..." - заканчиваете и результаты в студию.

0

33

andyshcher64 написал(а):

С полностью отцепленной сигнальной фишкой у вас уже опыт был.
Так?

Сейчас:
1 Оставьте прицепленным только провод СОМ.
Дальше поиграйте с портом.
Будет эффект?

2. Далее прицепите к фишке провод СТЕП.
Снова поиграйте с портом.
Будет эффект?

И т.д.

На какой стадии обнаруживается "Упппсссс..." - заканчиваете и результаты в студию.

Под эффектом мы же понимаем работающий драйвер? Если так, то как он будет работать, если у него в цепи будут отсутствовать элементы при последовательном подключении..?
О! При подключенном СОМ подключил СТЕП и движок застучал и загорелась зеленая. Подключил LPT - вырубился. Если просто СОМ подключить - драйвер не загорается даже.
Опытным путем выявлено, что зеленая загорается только при подключенном СОМ и СТЕП. С остальными контактами + СОМ драйвер не загорается.
Если трясти СТЕП то вал двигателя крутится  :jumping:

Отредактировано Geolog (26-06-2015 11:56:27)

0

34

Зеленая лампа должна загораться при подключении к драйверу его напряжения питания.
Эти кагбэ сообщается "Драйвер исправен. Напряжение питания Ок. Перегрева нет."

Есть импульсы на СТЕП, нет импульсов - это по барабану.

Кстати!
А что у вас установлено на ДИП-переключателях?

Сфотайте блок переключателей, плиз...

Отредактировано andyshcher64 (26-06-2015 12:12:59)

0

35

http://sh.uploads.ru/t/7Fqnz.jpg
http://sh.uploads.ru/t/wGHVc.jpg
http://sh.uploads.ru/t/wghWB.jpg

0

36

Был в отъезде некоторое время. Продолжим.

1. Блочок конфигурационных микропереключателей располагается между сисловой и сигнальной колодкой на драйвере.
Что вы на нем выставили? ЕГо фото и ваши установленные параметры.

2. Возьмите три батарейки и резистор 300 ом.
Соедините их последовательно.
Сделайте так, чтобы у данной гирлянды получились 2 длинных конца.

3. Найдите простенький стрелочный тестер
Поставьте его в режим измерения постоянного напряжения пределом 10 вольт.

Прежде чем начнем мучить девайсы:
Правильно ли я понимаю, что когда к драйверу подсоединены всего 2 провода (СОМ и СТЕП), при неинициализированном порте драйвер "горит зеленым", а при инициализированном "горит красным"? Согласно вашего поста № 33 ?

___________Добавлено:
Попробуйте микропереключатель № 1 перещелкнуть в положение ON
что-то изменится?

Отредактировано andyshcher64 (28-06-2015 14:04:23)

0

37

При СОМ и СТЕП горит зеленым, если трясти провод - двигатель дергается. Красный вообще не горит ни при каких обстоятельствах. Генератор на 5В и тестер приготовил.
http://sh.uploads.ru/t/CiO1g.jpg
http://sg.uploads.ru/t/hMtbc.jpg

0

38

Не мучайтесь , выдерните провода  енебл из драйвера и все поедет..

0

39

Судя по положениям микропереключателей SW1-SW7, у вас выставлено:

SW2-SW4
Микрошаг = 1
т.е. 200 импульсов на оборот

SW5-SW7
Ток = 1 А

Ок. Поехали.
Отцепите с сигнальной колодки все провода.

У вас есть гирлянда из "3-х батареек и резистора в 300 ом" в роли источника тока.
Поставьте тестер в режим измерения постоянного тока и возьмитесь концами тестера за концы гирлянд.
Таким образом, в режиме К.З. ваша гирлянда должна дать порядка 14 мА плюс/минус сколько-то там.

Подайте напряжение на драйвер.
Теперь кончиками гирлянды касайтесь входов СТЕП. Мотор должен бойко дергаться в одну сторону.

Далее.
Точно также подайте сигнал от гирлянды на пару EN.
Красная лампочка на драйвере загорится?
На какое время? Касания? Или Как выпало в красный так там и стоит?
Или вообще не загорается?
 
Делайте, пишите результаты, далее продолжим.

+1

40

на оптопару подавал родной сигнал драйвера +4,7в на стэп - двигатель дергался.
Главноt - при отключении порта LPT на контроллере горит зеленая лампа. (на всех контактах есть твердая единица 4,7 В!)
При включении порта на 10 раэъеме (ACK)  появляется единица, а на контактах данных 3,3В.
После чего на SP и DIR исчезает напряжение, и оно остается только на En.
светодиоды не горят, при отключении провода от анода оптопары EN ничего не происходит.

0

41

Проверьте 5 вольт приходит по кабелю юсб или нет.

0

42

Всё, запустил! Огромное спасибо Андрею "andyshcher64" за его помощь, без него я бы не справился. Проблема была в настройке Mach. Теперь одну ось закрутил, а если закрутилась одна - закрутятся и остальные :) Завтра буду протягивать провода и пытаться катать каретку  :cool:

P.S. Запуск первого шагового двигателя сравним с первой женщиной!

0

43

Geolog написал(а):

P.S. Запуск первого шагового двигателя сравним с первой женщиной!

Ахахах, это точно!!!

0


Вы здесь » Форум клана ЧПУшников » Станки с ЧПУ » Собираем станок плазменной резки