​ ​

Форум клана ЧПУшников

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » Форум клана ЧПУшников » Станки с ЧПУ » Вылетает NcStudio


Вылетает NcStudio

Сообщений 1 страница 21 из 21

1

Здравствуйте, Уважаемые форумчане.
Я недавно в этой теме, да и с компом на Вы. Возникла проблема, подскажите, что сделать и где посмотреть.
А проблема такая. Запустил чистовую обработку, было сделано процентов 60 рельефа и вырубилась NcStudio, полностью исчезла с "рабочего стола", фреза остановилась. Матюкнулся, запустил Nc снова, отправил фрезу в "домик", он сбился на 3 см влево. Установил снова, запустил станок, через 4 часа снова такой же сбой. Опять запускаю всё по новому, в этот раз "домик" ушёл вправо на 2 см.
Подскажите, что не так? Может с компом проблема?
С уважением.

0

2

фил63 написал(а):

Подскажите, что не так? Может с компом проблема?

Бывал такой вариант...Я или сносил винду и ставил Нсишку..Второй, отправлял плату в мусорник и менял(конечно если это дешевый китайский аналог))))

0

3

фил63 найдите небольшой винчестер и на него поставьте винду и Нцшку. Посмотрите в какую сторону будут изменения. Надеюсь механика станка осознано настороена?
Самый доступный метод замены и сравнения. Пользуйтесь им.

0

4

Скорое всего проблема в плате  :dontknow:

0

5

Спасибо всем за советы. Завтра буду пробовать на другом системнике. Сегодня всё переустановил, запустил, 12 часов работы и опять сбой. В первом часу ночи не стал разбираться, всё выключил и поехал домой

0

6

Vityshk написал(а):

Скорое всего проблема в плате


В плате какой? Материнке?

0

7

фил63 написал(а):

запустил Nc снова, отправил фрезу в "домик", он сбился на 3 см влево. Установил снова, запустил станок, через 4 часа снова такой же сбой. Опять запускаю всё по новому, в этот раз "домик" ушёл вправо на 2 см.
Подскажите, что не так? Может с компом проблема?

Такого быть не должно.
NCStudio привязыватся к концевикам и запоминает смещение рабочей системы координат относительно концевиков.

Я пробовал выдернуть компьютер из сети, выключить станок, сдвинуть руками оси станка, а потом запустить NCStudio, отправить на базу и продолжить работу - ничего не сбивается, NCStudio восстанавливает координаты по концевикам.

Надеюсь перед началом работы и указанием ноля рабочий системы координат вы отправляли станок на базу?

0

8

michael-yurov написал(а):

вы отправляли станок на базу?


Если под базой Вы подразумеваете заданный ноль  по х, у, то да , именно туда я его и отправлял перед стартом, но всё происходило именно так как я написал. Первый раз ноль ушёл влево, практически в ноль стола, Установил ноль снова, запустил, работает, второй сбой, отправляю фрезу домой, дом ушёл вправо , залез на рельеф.
Может оно и не должно такого быть, но было и есть. После сегодняшнего сбоя запускать не стал, третий день не могу закончить изделие  :tired:
Завтра программисты пусть ищут причину

0

9

фил63 написал(а):

Если под базой Вы подразумеваете заданный ноль  по х, у, то да

Под базой я подразумеваю машинный ноль станка, который ищется сразу после включения станка по концевым датчикам.

+1

10

А машинный ноль разве надо ставить после каждого включения станка? Я этого не делал. Закрепил заготовку, поставил ноль отсчёта координат (дом), откалибровал и старт. Всё шло нормально. Поставил машинный ноль (база) один раз и всё. Почему он должен сбиваться после каждого выключения?

0

11

Я запутался...

фил63 написал(а):

поставил ноль отсчёта координат (дом)

фил63 написал(а):

откалибровал

фил63 написал(а):

Поставил машинный ноль (база) один раз и всё


Что-то здесь не так...

Если не отправить станок искать машинный ноль (по концевикам), то он не сможет понять, где находится (мало ли куда переместили оси, пока станок был выключен).

И что-такое окалибровал - тоже не понимаю. Случайно не подстройка координат инструментом Jiggle?

0

12

michael-yurov написал(а):

(мало ли куда переместили оси, пока станок был выключен).

Я оси никуда не перемещаю, пока станок выключен.
А откалибровал, это выставил ноль по Z.

Станок вроде бы заработал. Взял другой системник, переустановил Винду и НсСдудио и всё пошло. Сбоев пока не было. Уже 6 часов работает.
Пока разбирался с этой проблемой, постоянно читал форум, узнал много для себя нового.
Всем огромное спасибо.
С уважением ко всем участникам форума

0

13

фил63 написал(а):

Я оси никуда не перемещаю, пока станок выключен.

В любом случае после подачи питания моторы НЕ встанут в прежнее положение.
Хотя бы из за того, что станок остановится, скорее всего, на дробной позиции микрошага, а после включения - будет нулевое смещение периода синусоиды микрошага, если только у вас драйверы не запоминают состояние (но и в этом случае, наверняка, будет смещение как минимум на +/- 4 полных шага).
В реальности станок перескочит на несколько шагов просто из за того, что ротор "примагниттится" уже к другому полюсу статора.

0

14

michael-yurov написал(а):

В реальности станок перескочит на несколько шагов просто из за того, что ротор "примагниттится" уже к другому полюсу статора.

как Вы считаете, необходимо каждый раз выставлять 0 руками после включения или же достаточно перед отключением станка отправить голову в дом? то бишь на координатыне нули.

0

15

netgad написал(а):

как Вы считаете, необходимо каждый раз выставлять 0 руками после включения или же достаточно перед отключением станка отправить голову в дом? то бишь на координатыне нули.

Я считаю, что лучше всего делать так, как рекомендуется в руководстве - после включения станка отправлять его искать машинные нули по концевикам,
а дальше - работать, как обычно.

Вручную (крутить винты руками) - вообще не предполагается двигать станок.

А перед отключением имеет смысл отправлять в на базу просто ради того, чтобы станок стоял "аккуратно припаркованный".

0

16

Я перед отключением отправляю шпиндель в дом , после того, как всё встало на свои места, выключаю станок, программу. Потом включаю, продолжаю резьбу с заданной точки (если работа ещё не закончена) и режу дальше. Никаких отклонений ни на шаг , тем более +/- 4 не происходит. Всё идёт нормально

0

17

фил63 написал(а):

Я перед отключением отправляю шпиндель в дом , после того, как всё встало на свои места, выключаю станок, программу. Потом включаю, продолжаю резьбу с заданной точки (если работа ещё не закончена) и режу дальше. Никаких отклонений ни на шаг , тем более +/- 4 не происходит. Всё идёт нормально

эммм... объясните как вы продолжаете работу если останавливаете станок и выключаете программу? он же заного начнет отсчет?то есть с начала программы. или я нуп и опозорился, чего то не знаю? :hobo:

0

18

netgad написал(а):

он же заного начнет отсчет?то есть с начала программы


Если Вы сделаете старт с нуля, то он начнёт заново. А если сделаете старт с того места, где остановили работу, то он с этой точки и начнёт резать

0

19

Посмотрите здесь NC-Studio пост 588.
В появившемся окне, в левой половине From: поставьте точку в position (Line number) и вводите нужную вам координату. Нажимаете ОК и всё ОК  :flag:

0

20

фил63 написал(а):

Я перед отключением отправляю шпиндель в дом , после того, как всё встало на свои места, выключаю станок, программу. Потом включаю, продолжаю резьбу с заданной точки (если работа ещё не закончена) и режу дальше. Никаких отклонений ни на шаг , тем более +/- 4 не происходит. Всё идёт нормально

Как интересно вам это удается?
Или вам просто хочется в это верить?

Каким образом вы проверяете в какое положение встал ротор двигателя после подачи питания?

0

21

michael-yurov написал(а):

интересно вам это удается?Или вам просто хочется в это верить?
Каким образом вы проверяете в какое положение встал ротор двигателя после подачи питания?


Понятия не имею, как мне это удаётся. Включаю и режу. Рельеф не страдает. А верю я в то, что вижу.
И ротор я никаким образом не проверяю. Даже представления не имею, для чего это надо делать.
Я же написал в своём первом посте, что я чайник. Мне как показали в первый раз, я так и делаю.
И сегодня запустил так, как написал раньше. Ни ноль машинный не устанавливал, ни положение ротора не проверял
Стану умным, как вы, может тогда и начну всё делать по умному
Вот как то так :blush:

Отредактировано фил63 (06-12-2013 16:36:57)

0


Вы здесь » Форум клана ЧПУшников » Станки с ЧПУ » Вылетает NcStudio