​ ​

Форум клана ЧПУшников

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » Форум клана ЧПУшников » Станки с ЧПУ » Странная проблема с пропуском шагов по Z


Странная проблема с пропуском шагов по Z

Сообщений 1 страница 59 из 59

1

Перелопатил форум вдоль и поперек. И не только этот. Ответа на вопрос так не от откопал.
Итак, станок самодельный, но на фирменных комплектующих. Контроллер на TB6560, китайская красная плата, двигатели по X - 2 штуки Nema 23_2430, по Y- один Nema 23_2430, по Z -Nema 23_6403. Блок питания - импульсник 36 вольт, 14 ампер. Везде стоят ШВП SFU1605. По X и Y рельсы SBR16, по Z рельсы SBR12.
Проблема пропуска наблюдается только по Z. Пропуск шагов только в одну сторону. Проще говоря, при обработке рельефа, фреза в какой то момент времени опускается на 0,5-0,7 миллиметра вниз и продолжает обработку дальше. Никакой закономерности в пропусках не нашёл. Пробовал обрабатывать один и тот же рельеф 10 на 10 сантиметров, ось Z может упасть вниз 5-7 раз за время обработки рельефа, а может и обработать нормально.
Кто может сталкивался с подобным, в какую сторону копать?

0

2

Вылечил уменьшением ускорения.

0

3

ось Z может упасть вниз 5-7 раз за время обработки рельефа, а может и обработать нормально

Возможные причины :
1) Станок не заземлен
2) Пропадает контакт кабеля оси Z
3) Большая подача и ускорение шагового двигателя ( временные пропуски шагов)
4) Подклинивает гайка
5) Нестабильная работа драйвера

0

4

Grant написал(а):

ось Z может упасть вниз 5-7 раз за время обработки рельефа, а может и обработать нормально

Возможные причины :
1) Станок не заземлен
2) Пропадает контакт кабеля оси Z
3) Большая подача и ускорение шагового двигателя ( временные пропуски шагов)
4) Подклинивает гайка
5) Нестабильная работа драйвера

Подпись автора

    Глаза боятся, а руки делают!

Все контакты проверены и перепроверены десятки раз.
Гайка не подклинивает - точно. Так же перепроверено. ШВП стоит новая.
Станок заземлен.
На этих режимах ускорения и подачи, станок уже работал и вполне благополучно, глюк вылез недавно.
Каналы управления драйвера менял Z и Y местами. Результата не дало.

0

5

Что значит

Сыч написал(а):

Результата не дало.

?
Дальше убегает по зет, или уже убегает по "У"

0

6

Так же убегает ось Z. Двигатель менялся на новый. Результата так же не дало...

0

7

Тут мысль пришла. А не может ли дело быть в проводах к двигателям? Токи довольно приличные, частоты тоже не самые низкие. Не может ли быть наведенных токов в проводах одного двигателя, от проводов другого?

0

8

Все контакты проверены и перепроверены десятки раз.
Гайка не подклинивает - точно. Так же перепроверено. ШВП стоит новая.
Станок заземлен.
На этих режимах ускорения и подачи, станок уже работал и вполне благополучно, глюк вылез недавно.
Каналы управления драйвера менял Z и Y местами. Результата не дало.

Еще возможные причины :
1) Если управляете станком ломаной  Mach 3 могут пропадать настройка оси Z
2) Пропадает промежутками  сигнал с платы опторазвязки  к драйверу.
3) Проверте  стабильны ли сигналы порта LPT
4) Желательно экранировать все кабеля идущие к шаговым двигателям

Отредактировано Grant (13-03-2013 16:24:47)

0

9

Сыч написал(а):

Проблема пропуска наблюдается только по Z. Пропуск шагов только в одну сторону. Проще говоря, при обработке рельефа, фреза в какой то момент времени опускается на 0,5-0,7 миллиметра вниз и продолжает обработку дальше. Никакой закономерности в пропусках не нашёл. Пробовал обрабатывать один и тот же рельеф 10 на 10 сантиметров, ось Z может упасть вниз 5-7 раз за время обработки рельефа, а может и обработать нормально.
Кто может сталкивался с подобным, в какую сторону копать?

Если пропуск только в одну сторону, и в минус (опускается на....), то у меня такая проблема была и вылечил я ее заэкранировав сигнальные провода с платы коммутации к драйверам
может быть я ошибаюсь в своей теории таких однобоких пропусков, но другой у меня нет
идея была в том, что наводимая с силового провода шпинделя переменка смещает уровень сигнала направления и драйвер в какой-то момент (момент смещения) считает что нужно ехать в другую сторону
особенно сильно это проявлялось когда экран кабеля шпинделя был заземлен на корпус станка

попробуй заземлить отдельным проводом драйвер по Зет и одень сигнальный провод управления (от платы коммутации до драйвера в экран, этот экран тоже заземли)
я еще запихал саму плату коммутации в металлический корпус и тоже заземлил его

должен сказать, что физической земли у меня нет, есть ноль на щите, земля в щите висит на нем же, пока сделать настоящую землю не представляется возможным
все провода заземления сведены в одну колодку и она уже отдельным проводом подключена к "земле" в щите

Отредактировано Evgeny (13-03-2013 16:36:16)

0

10

Сыч написал(а):

Тут мысль пришла. А не может ли дело быть в проводах к двигателям? Токи довольно приличные, частоты тоже не самые низкие. Не может ли быть наведенных токов в проводах одного двигателя, от проводов другого?

Так Вы ж писали

Сыч написал(а):

станок уже работал и вполне благополучно, глюк вылез недавно.

Что изменилось с того времени?

0

11

Grant написал(а):

1) Если управляете станком ломаной  Mach 3 могут пропадать настройка оси Z

Это как? Настройки в Mach никуда не девались. К тому же имею привычку файл конфигурации бэкапить.

Grant написал(а):

2) Пропадает промежутками  сигнал с платы опторазвязки  к драйверу.

Нет никакой платы опторазвязки. Всё собрано на одной плате. Я в первом посте описал.

Grant написал(а):

3) Проверте  стабильны ли сигналы порта LPT

Это как? А нестабильны могут быть как?

Grant написал(а):

4) Желательно экранировать все кабеля идущие к шаговым двигателям

А вот это - мысль. Только как экранировать, каждый провод в отдельный экран?

0

12

Роман С написал(а):

Что изменилось с того времени?

Ну как что? Появился глюк. При чем прямо во время обработки крупной модели.

0

13

Сыч написал(а):

Нет никакой платы опторазвязки. Всё собрано на одной плате. Я в первом посте описал.

это и есть она самая, плата коммутации или опторазвязки

0

14

Сыч написал(а):

Это как? Настройки в Mach никуда не девались. К тому же имею привычку файл конфигурации бэкапить.

Нет никакой платы опторазвязки. Всё собрано на одной плате. Я в первом посте описал.

Это как? А нестабильны могут быть как?

А вот это - мысль. Только как экранировать, каждый провод в отдельный экран?

Если нет возможности экранировать(экранируется весь провод) сделайте хотя бы витые пары для снятия наводящих токов, попрно каждую фазу.

0

15

Evgeny написал(а):

Сыч написал(а):

    Нет никакой платы опторазвязки. Всё собрано на одной плате. Я в первом посте описал.

это и есть она самая, плата коммутации или опторазвязки

Да, но КАК заэкранировать провода от платы опторазвязки до драйверов, если все это выполнено на одной плате?

0

16

stasblak написал(а):

Если нет возможности экранировать(экранируется весь провод) сделайте хотя бы витые пары для снятия наводящих токов, попрно каждую фазу.

Видимо я некорректно задал вопрос. Следует экранировать КАЖДЫЙ провод отдельно, или ПАРУ проводов каждой фазы двигателя?

0

17

Сыч написал(а):

...экранировать КАЖДЫЙ провод отдельно, или ПАРУ проводов каждой фазы двигателя?

Лучше экранировать все четыре провода (одним экраном) идущие на двигатель.

0

18

Сыч написал(а):

Да, но КАК заэкранировать провода от платы опторазвязки до драйверов, если все это выполнено на одной плате?

не понял, у вас плата и драйверы одно целое?

из всего, что я видел раньше, все выглядело так: комп с мач, с порта ЛПТ или УСБ по шнурку сигналы управления бегут на плату коммутации (опторазвязки), оттуда по шнуркам же идет управление драйверами осей

очень не плохо: использовать качественные кабели, лучше витые пары с "сильно" многожильным проводом и плетеным экраном; по возможности разнести друг от друга силовые и сигнальные провода; в идеале всю драйверную и управляющую электрику поместить в отдельный экранирующий кожух и заземлить его; инвертор шпинделя и силовой кабель шпинделя (особенно если он большой мощности, от 3 кВт и больше) вынести за пределы шкафа управления.

кстати, проблема носит постоянный или эпизодический характер?

Отредактировано Evgeny (14-03-2013 01:25:51)

0

19

rubicon.17 написал(а):

Сыч написал(а):

    ...экранировать КАЖДЫЙ провод отдельно, или ПАРУ проводов каждой фазы двигателя?

Лучше экранировать все четыре провода (одним экраном) идущие на двигатель.

Вот! Понятно. Попробуем так и сделать.

0

20

Evgeny написал(а):

не понял, у вас плата и драйверы одно целое?

Именно! Я об этом писал в самом начале.

Evgeny написал(а):

из всего, что я видел раньше, все выглядело так: комп с мач, с порта ЛПТ или УСБ по шнурку сигналы управления бегут на плату коммутации (опторазвязки), оттуда по шнуркам же идет управление драйверами осей

очень не плохо: использовать качественные кабели, лучше витые пары с "сильно" многожильным проводом и плетеным экраном; по возможности разнести друг от друга силовые и сигнальные провода; в идеале всю драйверную и управляющую электрику поместить в отдельный экранирующий кожух и заземлить его; инвертор шпинделя и силовой кабель шпинделя (особенно если он большой мощности, от 3 кВт и больше) вынести за пределы шкафа управления.

кстати, проблема носит постоянный или эпизодический характер?

Отредактировано Evgeny (Сегодня 01:25:51)

Комп с Мач, по LPT подключен к плате с опторазвязкой а драйверами. С платы кабели с многожильными проводами идут к двигателям.
Шпинделя пока нормального нет, больно цена у него кусается. Стоит обычный ручной фрезер 1.25 киловатта. Соответственно никакого инвертора тоже нет.  Кстати, мысль по поводу фрезера. Не стоит ли его питающий провод тоже заэкранировать?
Не очень понятно, что значит эпизодический? Попробую подробнее описать: Режу всем известную модель подкова с конём внутри. Она в сети валяется чуть не на каждом углу. Так вот, может полностью вырезаться нормально, а может 3-4 раза фреза упасть на 0.3-0.7 миллиметра вниз.

Отредактировано Сыч (14-03-2013 09:25:09)

0

21

Сыч, на своём самодельном станке поставил подтяжку по Z, т.е. компенсацию веса шпинделя, и заземлил металлокорд в стружко-пылеотводящем шланге (для снятия статики) - и подобная проблема вроде ушла.

0

22

Карпуха написал(а):

Сыч, на своём самодельном станке поставил подтяжку по Z, т.е. компенсацию веса шпинделя, и заземлил металлокорд в стружко-пылеотводящем шланге (для снятия статики) - и подобная проблема вроде ушла.

Подпись автора

    Ничего не сделано, если что-то не доделано.

Очень интересное решение. А каким способом делал подтяжку? Пружина, противовес, гидроцилиндр?

0

23

Сыч написал(а):

А каким способом делал подтяжку? Пружина, противовес, гидроцилиндр?

Лучший вариант это подобранная пружина, у меня на Комаграфе стоят такие по зет 2 шт с обеих сторон по зет.,  это быстродействие и проще крепить, и Т.Д. у всех остальных вариантов это непросто подобрать.

0

24

kartinka написал(а):

Сыч написал(а):

    А каким способом делал подтяжку? Пружина, противовес, гидроцилиндр?

Лучший вариант это подобранная пружина, у меня на Комаграфе стоят такие по зет 2 шт с обеих сторон по зет.,  это быстродействие и проще крепить, и Т.Д. у всех остальных вариантов это непросто подобрать.

Подпись автора

    Несправедливость не всегда связана с каким-нибудь действием; часто она состоит именно в бездействии.

Как то сразу в голову приходит, использовать пружины от того же ручного фрезера....

0

25

Сыч написал(а):

Так вот, может полностью вырезаться нормально, а может 3-4 раза фреза упасть на 0.3-0.7 миллиметра вниз.

это и есть эпизодически:) тогда все что я писал не подходит

а с цангой все нормально? бывает что плохо затянутая фреза выходит из цанги при работе

если фрезер щеточный, то он может "пылить" помехами в сеть, можно на фазовый провод шпинделя одеть ферритовое кольцо диаметром от 50мм пару раз продев провод через него, помехи на сеть уйдут, но скорее всего дело не в них.

я бы сначала проверил цанговый зажим.

0

26

Нет, дело точно не во фрезе. Я специально замерял вылет фрезы до начала обработки и после её окончания. Сегодня займусь экранировкой проводов. По результатам отпишусь.

Отредактировано Сыч (14-03-2013 15:38:13)

0

27

Проблема как у меня, один в один, проблема тоже проявилась не сразу. Мне помогло изменение ускорения двигателя по Z. Попробуйте поставить более медленное ускорение, хотя бы ради эксперемента. В целом от этого скорость почти не страдает.

0

28

Малахов написал(а):

Проблема как у меня, один в один, проблема тоже проявилась не сразу. Мне помогло изменение ускорения двигателя по Z. Попробуйте поставить более медленное ускорение, хотя бы ради эксперемента. В целом от этого скорость почти не страдает.

Возможно и так. Тут я думаю дело может быть в обкатке ШВП и линейных подшипников. То есть все элементы притёрлись друг к другу, ход оси стал легче и вес шпинделя стал достаточен, чтобы опустить ось Z. Тут я думаю, могут помочь и снижение ускорения и скорости оси, а так же организация подтяжки или противовеса. Будем пробовать.

Отредактировано Сыч (14-03-2013 16:32:47)

0

29

И муфту гляньте на всякий случай. Вряд ли, но чем черт не шутит. Может, ослабла - проворачивается почуть.

0

30

Поверил и муфту. Не проворачивается. Убавил ускорение. Вроде помогло, но не сильно. Пропуски есть, хотя гораздо реже. Заэкранировал часть проводов к двигателям, всё не успел, завтра доделаю - проверю и отпишусь. Похоже действительно, прикатались все соединения, ось ходит ОЧЕНЬ легко. Обратил внимание, даже при включенном станке, когда двигатели в режиме удержания, если как следует нажать на ось Z вниз, она сдвигается, проворачивая двигатель.

0

31

Длительность импульсов какая стоит в программе? mach3 используется?

0

32

Уважаемые форумчане!
Я не писатель, но хочется поделиться решением такой же проблемой и её решением.
У меня станок хоббийный.
Рабочее поле 800х600, ШВП 24х10, по Z- редуктор 4,5:1 привод- ремень, двигатели 18кг. ПО X Y стоят ремни от электро рубанков с редукцией примерно 1,6:1.
Контроллер китайский, микро шаг 1:16. Бегает шустро. Управляющий компьютер слабый- 500мгц,512, Mach3.
шпиндель стоит ручной фрезер 1200вт. Провода не экранированные. Провод питания шпинделя идёт в одном кабель-канале вместе с остальными.
Рано или поздно, нет нет, да пропустит пару шагов. это конечно очень доставало. Что самое интересное, чем сложнее рельеф, тем больше пропусков.
Пробовал менять скорость, ускорение, но ничего не помогало. Также было замечено, что пропуски начинаются когда включаются все три оси.
Я пришёл к выводу, что для "тяжелых" файлов компьютер слабоват.
Способов решения есть два.
Первый- приобрести новый, не ниже 1ггц с мощной видео картой.
Второй- перейти на другую управляющую программу.
Но я пошёл другим путём, я отредактировал скринсет и убрал картинку обрабатываемой детали, точнее сделал вторую страничку, на котором нет этого экрана.
оказалось всё банально просто, просто компьютер не успевал обрабатывать картинку и управлять станком.
После этих манипуляций- пропусков как не бывало.

0

33

AVV написал(а):

Длительность импульсов какая стоит в программе? mach3 используется?

Да mach3. А длительность импульсов это где?
Вообще, такое впечатление, что когда ось Z опускается, то она по инерции пролетает несколько шагов, а двигатель не осиляет её своевременно остановить.
Кстати, ускорение уменьшал дальше не куда. Не помогло.
Кстати, а не влияет ли на мощность удержания двигателя, настройка "спад тока" на драйвере?

Отредактировано Сыч (15-03-2013 22:09:04)

0

34

Сыч написал(а):

Да mach3. А длительность импульсов это где?

Там же, в motor tuning. Ставьте по максимуму - 5 мкс. И попробуйте режим sherline.

Вообще, такое впечатление, что когда ось Z опускается, то она по инерции пролетает несколько шагов, а двигатель не осиляет её своевременно остановить.

Напряжение питание какое? А максимальное для драйвера?

Кстати, а не влияет ли на мощность удержания двигателя, настройка "спад тока" на драйвере?

На удержание - нет. На динамику - да, но вряд ли. Есть еще вариант что оптопара не успевает отработать смену DIR - есть за mach3 такой грешок.

0

35

AVV написал(а):

Там же, в motor tuning. Ставьте по максимуму - 5 мкс. И попробуйте режим sherline.

Сегодня попробую.

AVV написал(а):

Напряжение питание какое? А максимальное для драйвера?

36 вольт. Максимальное для драйвера.

AVV написал(а):

Сыч написал(а):
На удержание - нет. На динамику - да, но вряд ли. Есть еще вариант что оптопара не успевает отработать смену DIR - есть за mach3 такой грешок.

С чего бы, она сначала успевала, а потом перестала, да ещё и по одной оси из трёх?

0

36

Нда. Продолжительные камлания и танцы с бубном, обнаружили пробой в одном из тригеров Шмидта, в микросхеме 74HС14D, стоящей на входе драйвера канала оси Z. Теперь ждём микросхему. За то по ходу камланий, заменил все кабели на экранированные, перепроверил все муфты, рельсы и подшипники....

Отредактировано Сыч (20-03-2013 09:47:43)

0

37

AVV написал(а):

режим sherline

Длительность импульсов, это я понял Dir/pulse и Step/pulse, на вкладке motor tuning.
А sherline это где?

0

38

Сыч написал(а):

Длительность импульсов, это я понял Dir/pulse и Step/pulse, на вкладке motor tuning.
А sherline это где?

Вот эти окошки, при упроавлении через LPT оптимально 5мс
http://s3.uploads.ru/t/V96FL.png

0

39

Сыч написал(а):

А sherline это где?

http://s2.uploads.ru/t/9oMXe.jpg

0

40

stasblak написал(а):

Вот эти окошки, при упроавлении через LPT оптимально 5мс

.

Ну да, так у меня и стоит.
По режиму sherline: по пробую. А что он даёт? Как работает?

Отредактировано Сыч (20-03-2013 13:48:19)

0

41

Подскажите - та-же проблема. Только вопрос такой вы се указываете в Mach я использую Turbocncn, так там стоит стартовая скорость и ускорение, какую скорость ставить от максимальной или это только пробами?

0

42

vitaalex написал(а):

- не используйте импульсные блоки питания.

У меня тоже красная плата, я тоже начинающий, поэтому интересует почему импульсник не подходит? У многих стоят на этих платах такие БП. Пока проблем из за этого не наблюдал, но для развития интересно.

Сыч написал(а):

использовать пружины от того же ручного фрезера....

Себе поставил от старого экспандера, эти пружины довольно долговечны.

0

43

vitaalex написал(а):

В итоге, что хочу сказать - начинайте с простого и все придет с опытом.

Что касается меня, то немного поздно, все уже случилось.
В этой теме немного есть - мой первенец
На работу мой импульсник особо вроде не влияет, но заземлил все и экранировал тоже, то есть каждый кабелек, даже на обычные (контактные) концевики.
Ну может поэтому и не глючит, я в этом не силен. Единственная проблема (из за этого немного пожалел о выборе) была - БП начал выдавать вместо 34 вольт - 37. Причину так и не нашли, она самоустранилась.

0

44

Мы подобную проблему решили гораздо проще, надо проверить затяжку муфты по оси Z и просто хорошо подтянуть, даже если кажется, что там всё в порядке.

0

45

Олег В написал(а):

Мы подобную проблему решили гораздо проще, надо проверить затяжку муфты по оси Z и просто хорошо подтянуть, даже если кажется, что там всё в порядке.

Что за муфта? Где находиться и как выглядит?Чем зажать?

0

46

Имеется ввиду соединяющая двигатель привода оси "Z" с валом ШВП

0

47

Grant написал(а):

ось Z может упасть вниз 5-7 раз за время обработки рельефа, а может и обработать нормально

Возможные причины :
1) Станок не заземлен
2) Пропадает контакт кабеля оси Z
3) Большая подача и ускорение шагового двигателя ( временные пропуски шагов)
4) Подклинивает гайка
5) Нестабильная работа драйвера
Подпись автора
Глаза боятся, а руки делают!

Доброго времени суток.
у нас самоделка
тоже была проблема с пропусками по Z
после того как прошлись по всем выше перечисленным пунктам.
нашли беду там где не ждали
опорный подшипник вышел из строя и подклинивал в самый неожиданныйhttp://s6.uploads.ru/t/ERzbG.jpg
момент

0

48

Кенгуру написал(а):

Доброго времени суток.
у нас самоделка
тоже была проблема с пропусками по Z
после того как прошлись по всем выше перечисленным пунктам.
нашли беду там где не ждали
опорный подшипник вышел из строя и подклинивал в самый неожиданный
момент

  За муфту спасибо,посмотрю если болтаеться то подтяну, да даже если и неболтаеться то всё равно подтяну.А вот про гайку совсем непонятно.Что за гайка, каторая может подклинивать?Где находиться? Мне когда пришол станок в упаковке, на дне её я нашёл алюминевую гайку с резьбой, ты про неё говоришь?.К стате коворя, эта гайка оказалась от моего шагового двигателя каторый стоит по Z.Только что сходил да посмотрел, нету с торца двигателя нифига, завтра накручу её.Вот осенила ещё мысль, рядом то с гайкой лежало 4-ре болта, теперь гоняю от чего они там оказались.PS: а может ты другую какую гайку имеешь ввиду?

Отредактировано paVels (14-11-2013 02:00:20)

0

49

vitaalex написал(а):

Я, вообще-то имел ввиду, что для начинающих чпушников лучше использовать вместо импульсника трансформатор с запасом по мощности и обычный выпрямитель с набором конденсаторов, зашунтированных керамикой. У меня есть солидный опыт в сборке механики станков и электроники, собрал более десятка на шд и серве с энкодерами и советую не начинать с импульсников. Они могут быть сильным источником помех, которые скажутся на работе станка, а вы будете ломать голову и метаться по форумам. Начните с простого. Работа с импульсными приборами предполагает некоторые знания в области помехозащищенности - как заземлить, что заземлять, куда прицепить землю, как и куда подключить экранирование, что экранировать, как экранировать, как рассчитать подтягивающие резисторы с опторазвязке или LPT....... Я могу еще продолжить на целую страницу. В итоге, что хочу сказать - начинайте с простого и все придет с опытом.

Станок самодельный, включая драйвера и блок питания. БП на трансе от старых телевизоров - ТС180-2, который хорошо разбирается и наматываются нужные обмотки. На управление драйверов +5 и +15В стабилизированное питание от обмоток 8 и 17В, а на питание силовое ШД выпрямитель с емкостями 10тыс мкФ. Этого транса хватает на 2 ШД на 18кг и один на 31кг. Транс чуть теплый после 8 часов работы.
Это я к чему - станок не заземлен ни разу. Питание компа,драйверов, шпинделя от одной розетки. Все пропуски которые случались - только по причине механики. Может действительно потому что БП на трансе?
Плюс крепление шпинделя из за жабы которая не дала купить металлическое крепление, сделано из оргстекла - т.е. шпиндель гальванически не имеет связи с металлом станка.

0

50

У меня была точно такая же проблема и контролер был такой же, ось Z косячила бесконечно, сначала я грешил на механику оси, думал, что может винт имеет биение и подклинивает или направляющие имеют косяк, все проверил, ни чего не нашел. Короче подключил я в контролере вместо оси Z ось X (поменял местами) в Mach поменял настройку соответственно и просто афигел ось Х начала косячить, а ось Z отлично стала работать. Я купил новый контролер PLC 330b и все мои мучения полностью закончились. По китайcкому контролеру перерыл весь интернет и не только. Косяк скрывается в прошивке 100%. Не мучайся купи нормальный контролер и работай. Я купил в пурелоджике. Удачи!

0

51

Grant написал(а):

Nema 23_2430

Здравствуйте.У меня станок из мдф.Очень жёсткий.Контролер ТВ6560 синяя плата. Ось Z тоже убегает.На оси Стоит ШВП.  Ещё вопрос как заземлить станок из МДФ???

0

52

tarasov написал(а):

как заземлить станок из МДФ

Деревянным проводом!
:D
А если серьезно - задумайтесь о замене драйверов.
У самого была такая плата синяя.
Намаялся.
Если финансы сильно жмут - ставьте в дальний план новые драйвера,
а сами - допаивайте плату.
Немножко, но помогает.
http://bdyssh.ru/dorabotka-kontrollera- … lue-board/

0

53

andyshcher64 написал(а):

Немножко, но помогает.
http://bdyssh.ru/dorabotka-kontrollera- … lue-board/

Отличная ссылка, спасибо!

А не подскажете, тоже самое касается красного контроллера?
У меня на четыре оси... такой - http://www.ebay.com/itm/4-axis-TB6560-s … 45fca29ab8
три трёх амперных движка, блок питания - импульсник  24В, 11А.  Впринципе всё работает,  но иногда почему-то не приезжает в ноль после выполнения программы, не так чтобы прям конкретно мимо, но на глаз заметно. 
Что за настройка такая спад тока? 
Так как руководство не соответствует реальности... подбирал всё методом научного тыка...  микро шаг - легко установить по расстоянию, пройденное кареткой, сразу понятно что выставил не то, которое хотел.  ...  а вот ток и этот спад  подбирал, подключив амперметр к одной из обмоток, и абы как переключая джамперы (конечно с выключением питания) . 
Так вот получилось - максимальный ток при работе двигателя  1.5А переменный, то есть амплитуда около 2.1 А .  При удержании - 0.5А постоянный. К
Когда удержание двигатели зудят, противно так... вроде бы не очень громко, но напрягает.. и если положить руку на двигатель то осязается мелкая вибрация.  Если поиграться джамперами спада тока то можно добиться того, что будет тихо, но при этом ток обмотки становится маленьким - 0.7А переменки (((   ,  Добавлю ещё что двигатели не греются ни грамма,  максимально сколько работал без перерыва - где то минут 40... - чуть-чуть тёплые, ну градусов 20... при температуре воздуха +10

В связи с этим вопросы... как всё таки заставить контроллер выдавать полный ток?  должен 3А... а выдаёт 2.1...
Почему в удержании зудят движки?  помогут ли переделки в ссылке выше это поправить?

Уж извините, если вопрос глупый...  вроде попробовал поиском про зуд движков - ничего не нашел ((

Отредактировано Superbizon (03-04-2014 17:04:31)

0

54

Superbizon написал(а):

А не подскажете, тоже самое касается красного контроллера?

Схемотехника синих и красных хоть немного - но разная.
С другой стороны... идея, которую высказывали на сайте "БДЫЩ", заключалась как раз
в том, чтобы сделать "отдельно" силовую землю.
Думаю, все это будет применимо и к красному контроллеру.

Далее. "Шипение" или "писк" двигателей.
Не вспомню сейчас сразу где видел, но была такая доработка, которая
как раз заключалась в замене кондеров,  задающих частоту ШИМ-регулятора тока.
Возьмите оригинальный даташит от этого пресловутого чипа тошибовского.
В документе есть типовая схема применения.
Гляньте там, сколько у них поставлено, и в каких пределах можно эту частоту менять.

Кстати, вы сами будете эти операции делать?
Если нет опыта в радиогубительстве, то лучше все же обратитесь к другу, который
"родился с паяльником в руке".
Эти чипы привередливые. Чуть что не так - и синий дым.

Ток, который отдается на обмотки, лучше глянуть на токоизмерительном
резисторе в составе схемы контроллера.
И смотреть все это с помощью осциллоскопа.

И напоследок традиционное пожелание заменить драйверы на нормальные,
пусть даже начального уровня.

0

55

Спасибо за развёрнутый ответ...
Вот наконецто до неё дошли руки...   А всётаки схемотехника красной от синей отличается довольно сильно, в лучшую сторону.
Но земли я всётаки пропаял, не зряже выкорчёвывал из станка )))  ещё параллельно электоролитам у каждой TB6560 приляпал по плёночному кондёру ( сверлить как в статье не стал)
вот вообщем что вышло -

http://sb.uploads.ru/t/2NT5U.jpg

Прежде чем вынуть контроллер из станка, сделал трёх канальный выравниватель фронтов, на АС14..  для сигналов SCK...  на синих контрллерах на TB6560 идёт сразу после опртронов... а там фронты не очень вот и возникают пропуски и прочие прелести. Решает проблему разрыв и впердоливание в эту цепь повторителя с гистерезисом.  Но оказалось, что на красной плате это всё уже есть, так что если кому надо - обращайтесь, отдам за пиво )) ...  ну ладно-ладно и просто так отдам )) (в москве).
фото девайса -
http://sa.uploads.ru/t/oOdjU.jpg
всё просто +5,  земля  и три входа-выхода.

Отредактировано Superbizon (16-04-2014 18:17:33)

0

56

Вчера вставил обратно в станок...  вроде бы зудит меньше и стал кататься на 3500 мм/с,  раньше на 2500 уже затыкался.
Но не совсем понятно с чем связаны улучшения, так как я ещё и накрутил блок питания на максимум - 27.4 вольт. ( раньше было ровно 24).
Кстати, никто не знает как блок питания раскочегарить ещё больше? БП  meanwell NES-350-24.

0

57

Superbizon написал(а):

как блок питания раскочегарить ещё больше? БП  meanwell NES-350-24

Можно ,но проблематично ,сам пробовал .Для хорошего результата надо перематывать трас в силовом преобразователе ,заменить несколько конденсаторов на более высоковольтные и еще много чего. Можно ,конечно ,и так накрутить ,но это очень рискованно в плане надежности .Не заморачивайтесь ,замените БП на необходимый ,в конечном результате будете в выиграше .

0

58

Столкнулся с аналогичной проблемой, но по оси Х. Пропуски шагов в одну сторону. Менял всё - от драйвера и ШД, до проводов и ускорений. Не помогало. Причина оказалась банальной - обломился ус, который держит канал перетока шариков в гайке. В одну сторону он пропускал без каких-либо проблем, во вторую - шарики иногда подклинивало в ложбинке, оставшейся от уса крепления канала. А с виду всё хорошо и движение гайки по винту кажется ровным. http://s7.uploads.ru/t/P9s68.jpg

0

59

Здравствуйте.
Тоже мучился такой проблемой.
Было 2 разных станка. И на обоих Z уходила вниз.
Проблема решилась, когда поставил более мощные двигатели на Z.

0


Вы здесь » Форум клана ЧПУшников » Станки с ЧПУ » Странная проблема с пропуском шагов по Z