​ ​

Форум клана ЧПУшников

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » Форум клана ЧПУшников » Станки с ЧПУ » Помогите со станком!


Помогите со станком!

Сообщений 1 страница 9 из 9

1

Люди, помогите решить проблему: выполняю прогон (через Mach3), в одну сторону двигается нормально, а в обратную рывками и с жужанием, такое по всем трем осям. Причем такая закономерность : при первом включении все двигалось нормально но ось Х была инвертирована, поставил флажок Dir Low Active - двигается в правильную сторону но в обратном направлении рывками.

0

2

попробуй уменьшить максимальную скорость
нужно посмотреть что у тебя стоит в настройках мача по длительности импульсов степ и дир(попробуй увеличить значение)
стоит ли степ активный низкий уровень?
а может банально посмотреть механику?
прогони дополнительно тест порта
чудес не бывает.... их создают люди

0

3

Скорость уменьшал, в принципе не влияет (рывки стали только по оси Z, но  проблема осталась).
Пробовал увеличивать длительность импульсов - становится только хуже, а вот уменьшение помогает, выставил step pulse -3 и dir pulse -  тож 3 (производитель советовал 10 и 3 соответственно).
При выставлении только Step Low Active работает нормально без рывков, только ось Х инвертирована, НО при включении шпинделя стал срабатывать E-stop с интервалом в 10 секунд, и в простое и при выполнении УП.
С механикой вряд-ли , так как прогон по всем осям работает норм (при Step Low Active, а если поставить Dir Low - то рывками или вообще  заедает).

НО один нюанс, у меня станок подключен к ноутбуку через переходник LPT-ExpressCard.
P.S. Да, я знаю что все переходники только эмулируют LPT порт, потому вообще не надеялся что заработает, но факт - в принципе станок работает!
И большое спасибо за советы!

0

4

evgenius написал(а):

С механикой вряд-ли , так как прогон по всем осям работает норм (при Step Low Active, а если поставить Dir Low - то рывками или вообще  заедает).


Поставь Step Low Active, если с ним работает нормально,  а для смены направление поменяй на проводах  двигателей, в каждой паре начало с концом.

0

5

evgenius написал(а):

При выставлении только Step Low Active работает нормально без рывков, только ось Х инвертирована, НО при включении шпинделя стал срабатывать E-stop с интервалом в 10 секунд, и в простое и при выполнении УП.

видимо идут наводки на неэкранированные провода в стойке управления
какой шпиндель безколлекторник или со щетками?
по поводу ноута- пробовал и от применения отказался- мощности порта не хватает потери по сигналам проскакивали-купи недорого мать, проц, память, видеокарту на радиорынке и забудешь про проблемы- собрал всё в одном флаконе- в железном электроящике- наружу только клава, монитор разъём под флешку и мышку

0

6

Послушался совета и собрал стационарный комп, только вот не знаю какую плату для порта LPT купить, чтобы в PCI слот на метеринской плате.
Спецы, посоветуйте  ;)

0

7

этот   
должен подойти

0

8

Подойдет любая плата. вопрос в том что некоторые не поддерживаются в win7, дрова отдельно искать придется для нее (т.к. на дисках производителя может не быть). А так в пределах 370 рублей.

0

9

Большое спасибо всем! Заработало!!!
P.S. А плату купил  такую.

0


Вы здесь » Форум клана ЧПУшников » Станки с ЧПУ » Помогите со станком!