Форум клана ЧПУшников

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » Форум клана ЧПУшников » Станки с ЧПУ » Сбой при перемещениях в Mach3


Сбой при перемещениях в Mach3

Сообщений 1 страница 9 из 9

1

Суть проблемы: при дискретных перемещениях в ручном режиме по любой из осей происходит стук, координата сбивается. Судя не нескольким запоротым деталям, сбой происходит и при выполнении УП. Перепроверил все что можно, при тестовых прогонах станок нигде не клинит, возращается в точку (судя по индикатору и меткам на валах) с точностью 0,01. Начинаю привязываться к поверхности по касанию - происходит сбой. Закономерности проявления сбоя выявить не удалось. Приняты были следующие меры - прозвонил провода, все заземлил, частотник убрал подальше от всей остально электроники, все подтянул, смазал, скорости и ускорения занизил. MACH лицензионный, комп достаточно мощный. Контроллер PLCM-e3P На плате PLCM-b1 (это пурелоджик), драйвера leadshine dm856. ШВП клинить не может, ибо их нет, стоят пластиковые резьбовые втулки с выборкой зазора. Где еще искать причину?!

0

2

Cucumber написал(а):

Контроллер PLCM-e3P На плате PLCM-b1 (это пурелоджик), драйвера leadshine dm856

У меня знакомый так и не смог запустить такую связку электроники.
Перепробовал всё......в ПЛ, тоже не смогли объяснить такое поведение этой связки.
У него были проблемы в уходе координат.
Сейчас пробует исключить из этого комплекта PLCM-e3P и PLCM-b1.

0

3

Раньше этот PLCM работал в связке с PLC545, таких проблем не было. Так что, может быть, действительно проблема в PLCM-b1?

0

4

Cucumber написал(а):

Где еще искать причину?!

Какой у Вас станок-- самодельный?Уже работал нормально и появились эти сбои,или только приступили к настройке?Стуки идут с включенным шпинделем,а с выключенным нет?

Cucumber написал(а):

Начинаю привязываться к поверхности по касанию - происходит сбой

Такое бывает от наводок.Первым делом заэкранируйте кабели к шаговым двигателям.Проверьте целостность экрана кабеля LPT и проложите его подальше от всех других кабелей.Перемещайте оси с полностью отключенным частотником.Подключите станок к другой розетке,которая запитана,по возможности,более толстым кабелем.Могут ли поступать помехи из сети--работа где-нибудь рядом мощных потребителей.

0

5

Спасибо за комментарии.
Станок - американский роутер Gerber Dimension, старенький, но вполне добротный, качество обработки весьма хорошее. Раньше работал на PLC545, медленно, но проблем с качеством и сбоями не припомню. Сбой происходит и при выключенным шпинделем, но включенным частотником. LPT кабель отсутствует, соединение контроллера осуществляется по ethernet.
Мощных потребителей поблизости не наблюдается.

0

6

Cucumber написал(а):

Раньше работал на PLC545, медленно, но проблем с качеством и сбоями не припомню.

Ну вот Вам и ответ.

0

7

Cucumber написал(а):

Раньше этот PLCM работал в связке с PLC545, таких проблем не было. Так что, может быть, действительно проблема в PLCM-b1?

Ответ простой Нужно работать с электронникой одного производителя, а не собирать гибрид из продукции разных производителей.
В Европе подписаны договоры между крупными производителями, и они придерживаются единного стандарта, а вы пытаетесь Китай подружить с Россией.
PLCM-B1 не является причиной вашей проблемы, а компании не наруку решать проблему привязки оборудования реального конкурента, так что думайте что вам будет дешевле Приобрести драйвера PLD880, или преобретать китайский аналог комплекта контроллера и платы опторазвязки?

Отредактировано stasblak (11-06-2013 12:45:01)

0

8

То есть возвращаться на PLC545? Что-то я склоняюсь уже к тому, чтобы поставить NC Studio. Утомили эти пляски с мачем и пурелоджиком.

0

9

Cucumber написал(а):

То есть возвращаться на PLC545? Что-то я склоняюсь уже к тому, чтобы поставить NC Studio. Утомили эти пляски с мачем и пурелоджиком.

))))  может быть и правда стоит перейти на NCStudio за 1500 руб.

Сами по себе драйверы не глючат, они работают у многих пользователей и проверены годами.

А вот PLCM... проблемная штука. Отчасти из за Mach3, отчасти из за неправильного подключения к питанию, отчасти из за своего плагина и прошивки.

У меня работала подобная связка, и никакой несовместимости драйверов Leadshine с контроллером PLCM я не заметил.

А! еще! у меня PLCM упорно глючил с дешевыми картами DLINK!
Пока я не поменял карту на дорогую (кстати - тоже DLink) у меня происходили сбои в самых разных местах.

Отредактировано michael-yurov (11-06-2013 16:45:01)

0


Вы здесь » Форум клана ЧПУшников » Станки с ЧПУ » Сбой при перемещениях в Mach3