​ ​

Форум клана ЧПУшников

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » Форум клана ЧПУшников » Станки с ЧПУ » Проблема с осью z


Проблема с осью z

Сообщений 1 страница 25 из 25

1

Проблема заключается в слелующем:
При обработке постепенно поднимается шпиндель.К примеру,на расстоянии 300мм по оси X при растровой обработке  ось Z понимается на 4мм.
При возврате в ноль счетчики в MACH3 показывают нули.По осям X и Y  шпиндель  действительно приходит  в первоначальное положение,а реальное положение оси Z на 4мм выше.
Заметил,что чем сложнее рельеф ,тем выше поднимается ось Z.
Ось Z   фирменная  IAI 150,в отличном состоянии,муфта не прокручивается,люфта нет,смазка есть,не подклинивает.
Сервомотор 60w  питание 80в от импульсного БП
Все провода экранированные и  помещены в общий экран ну и соответствено заземлены.
Уровень сигналов с энкодера 5в
Управляющая программа MACH3
Компьютер хороший 2ГГЦ,управление станком по LPT
Скорость двигателя по Z  2м/мин

0

2

калибровку оси z проводили? количество импульсов выставили правильно?
в маче функция мастера цикл сверления - вместо шпинделя стрелочный индикатор- цикл с шагом 0,1 мм глубиной мм 100- чтоб подольше погоняло и потом  возврат в ноль по индикатору
и потом попробовать менять длительность имп направления-может быть причина- низкая скорость опторазвязки-уже неоднократно об этом писали, просмотреть правильность пересчета мачем линейных перемещений- такая функция в маче - автонастройка пересчетного коеф тоже есть- это маловероятно т к при этом было бы просто неправильная геометрия но возврат в ноль бы не страдал
а можно просто попробовать поменять драйвера местами и отследить изменится ли погрешность на другую ось....
возможна также проблема с портом LPT- просто попробуйте комп поменять и отследить где проблема - в драйверах или в компе
по поводу индикатора мача, который показывает ноли- они никак не связаны с реальными значениями- там индицируется только математика....

0

3

vovapzb1 написал(а):

Управляющая программа MACH3

Лицензия или народная?

0

4

Mach3- лицензионный.
Проводил такой эксперимент.Написал циклическую программу опускание  на -10 и возврат в 0.Всего 100 циклов.После отработки программы и возврата 0  замерил зазор,ни каких отклонений не обнаружил.Может быть мало циклов.
Сервоконтроллер стоит ADR940.

0

5

проверяйте на максимальных скоростях, может в этом причина

0

6

Попробуйте проверить плотность зажатия всех контактов на всех разъемах.
Заметьте, может какие-то внешние факторы влияют на передачу данных от компа к устройству сопряжения.
У меня был такой случай: в момент разгона шпинделя наводилась наводка на сигнальный кабель и то же, не понятно почему, страдала ось Z.

0

7

возникла такая же проблема! только во время фрезеровки шпиндель медленно плавно но верно опускается вниз...Проблему пока не решил...Все проверил... Похоже драйвер барахлит...

0

8

mixey86 написал(а):

возникла такая же проблема! только во время фрезеровки шпиндель медленно плавно но верно опускается вниз...Проблему пока не решил...Все проверил... Похоже драйвер барахлит...
Подпись автораговорим спасибо, ставим плюсы...

А у вас какой двигатель и драйвер?

0

9

vovapzb1 написал(а):

При обработке постепенно поднимается шпиндель.

В тему про МАЧ загляни,такую-же проблему решал......

0

10

Доброй ночи мужики! Помогите решить проблему. При чистовой обработке модели ось Z уходит постепенно вниз. Контролер синий китаец скорость 1100 ускорение 500 на других осях те-же цифры, но смещение нет. В чём проблема? Спасибо за помощь.

0

11

у меня муфта на оси Z лопнула и тоже уходила в низ. ослабило крепление на винте и в момент остановки по инерции винт смещается еще на на пару десяток

0

12

Ворент написал(а):

у меня муфта на оси Z лопнула и тоже уходила в низ. ослабило крепление на винте и в момент остановки по инерции винт смещается еще на на пару десяток

Спасибо за ответ, но дело не в муфте

0

13

попробуй ускорение поменьше поставить- 100 или 150 - возможно масса оси z при реверсе играет злую шутку- появляется пропуск шагов из за инерции
в принципе уменьшить до 20 и вхолостую поганять, увидеть прошла ли проблема
фотку оси скинуть можешь?

Отредактировано алекс (09-09-2012 00:29:32)

0

14

алекс написал(а):

попробуй ускорение поменьше поставить- 100 или 150 - возможно масса оси z при реверсе играет злую шутку- появляется пропуск шагов из за инерции
в принципе уменьшить до 20 и вхолостую поганять, увидеть прошла ли проблема
фотку оси скинуть можешь?

Отредактировано алекс (2012-09-08 23:29:32)

Ставил ускорение  от 10 до 200, скорость от 500 до  1000, менял движки местами , но проблему не решил

0

15

Была проблема с уходом зэт в верх.Оказалось, банально наводки на провод от компа.Закинул в металлорукав,заземлили и проблема ушла.Наводки идут от блоков питания,частотника.Мач лицензионный-значит он глюков не даст точно.

0

16

попробуй переназначить каналы в маче (поменять номера пинов и выходы моторов)это даст возможность проверить сидит ли проблема в механике или электронике- про экранирование правильно выше писали- полезная штука- сфоткай шкаф электроники давай вместе посмотрим- может что умное ии прийдет в голову o.O
про синий китаец- в соседнем форуме писали про них- там вроде оптроны не сильно быстрые- поэтому иногда потеря шагов- там пришли к выводу, что ток через оптроны занижен- вроде так- проверяется точным измерением ограничивающих ток резисторов-входная цепь

Отредактировано алекс (10-09-2012 23:23:16)

0

17

И у меня была подобная проблема, как-то подкорректировал старую программу и по оси Z шпиндель стал опускаться вроди все по старому другие программы нормально работают. оказалось что в чистовой обработке я установил точность 0.01 а не 0.05 как обычно.

0

18

eliseyka написал(а):

Была проблема с уходом зэт в верх.Оказалось, банально наводки на провод от компа.Закинул в металлорукав,заземлили и проблема ушла.Наводки идут от блоков питания,частотника.Мач лицензионный-значит он глюков не даст точно.

О каких проводах от компьютера идет речь?Если LPT,то он на сто процентов защищен от помех.Если USB,то он тоже экранированный.

0

19

vovapzb1 написал(а):

Ось Z   фирменная  IAI 150,в отличном состоянии,муфта не прокручивается,люфта нет,смазка есть,не подклинивает.
Сервомотор 60w  питание 80в от импульсного БП

Подобные ещи происходили
1 плохо зажата фреза(уходит верх)
2большая скорость(уходит в осноном вниз)
3муфта(уходит куда угодно)
4слабый блок питания(отключи все оси .оставь одну и запусти программу на которой уходит если все ок блок питания)
5бывает материнка в маче есть тест файл там все понятно.1 раз такое было проц хороший а мать срывает импульсы

Отредактировано yuric73 (13-09-2012 16:06:50)

0

20

vovapzb1 написал(а):

eliseyka написал(а):

    Была проблема с уходом зэт в верх.Оказалось, банально наводки на провод от компа.Закинул в металлорукав,заземлили и проблема ушла.Наводки идут от блоков питания,частотника.Мач лицензионный-значит он глюков не даст точно.

О каких проводах от компьютера идет речь?Если LPT,то он на сто процентов защищен от помех.Если USB,то он тоже экранированный.


разьем лпт,но он к сожалению он ловит все на свете даже с феритами(проверено горькими танцами с бубном).

0

21

yuric73 написал(а):

5бывает материнка в маче есть тест файл там все понятно

Опишите подробнее этот пункт.Где найти тест файл?

0

22

наверное речь идет Driver test.exe?  находится в корневой папке мача

0

23

алекс написал(а):

наверное речь идет Driver test.exe?  находится в корневой папке мача

Спасибо!Драйвер нашел и протестировал компьютер-все нормально.

0

24

С тех пор как открыл эту тему проделал следующую работу
1 Поменял драйвер
2 Заменил ось на IAI 250 c серводвигателем 100вт (стояла IAI 150 с двиг 60вт)
3 Все драйвера и блоки питания встроил непосредсвенно в станок,с целью уменьшения длины кабелей.
4 Поменял кабель ЛПТ на другой с витыми парами и экранированный.Кабель который поставляет PURELOGIC  не имеет ни какой защиты!!!
5 В SETUP установил тип ЛПТ порта   EPP (усиленный)
6 Уменьшил скорости по всем осям до минимума
7 Поставил на максимум длительность импульсов DIR
Не получил ни какого результата.За один час работы при растровой обработке ось Z поднимается на 1мм

0

25

Проблему решил заменой серводвигателя на шаговый.Запустил растровую обработку на 4 часа-ни каких отклонений по оси Z.

0


Вы здесь » Форум клана ЧПУшников » Станки с ЧПУ » Проблема с осью z