Форум клана ЧПУшников

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » Форум клана ЧПУшников » Станки с ЧПУ » Шпиндель и mach3 не дружат...


Шпиндель и mach3 не дружат...

Сообщений 1 страница 26 из 26

1

здравсвтуйте всем!  короче,имею гравировальный станок-планшетник от Зенона. нареканий не было вообще,но пару дней назад появился косяк. шпиндель не запускается!тоесть включаем станок,комп выключен,все нормально,включаем комп,теперь можно регулировать обороты с инвертора,все ок,открываем мач3 и тут начинается квэст) шпиндель отключается,пишет Н 0,0 - тоесть показывает что комп не подключен. перепроверил все соединения и на станке и на компе,снес и установил мач3,не помогает. попробовал подключить другой комп,установил на него мач3,тот вообще не откликается.
вобщем шпиндель вырубается при открытии мач3,при этом шаговые моторы работают,можно двигать стрелками по осям z,x,y,но  шпиндель не запускается.после перезагрузки компа,шпиндель снова работает,ровно до того момента,пока не запустим мач3. а и еще,после того как шпиндель вырубается,можно вытащить провод LPT и шпиндель начинает работать...что это за ерунда?куда копать?очень прошу помощи...

0

2

Смотрите, возможно земля гуляет где-то

0

3

ruslan.drn написал(а):

Смотрите, возможно земля гуляет где-то

не силен в электронном сленге,проще говоря я нуб) тоесть проверить заземление?да,и кстати,заметил что станок стал немного бить током,когда дотрагиваешься до корпуса.

0

4

ruslan.drn написал(а):

Смотрите, возможно земля гуляет где-то

только что кинул дополнительный провод на заземление,ничего не изменилось...

0

5

kuvatinus
Включайте в ручную шпиндель из программы (можете нажать на F5) и прислушайтесь, есть ли щелчок реле(примерно куда кабель подключен)...

0

6

skedram написал(а):

kuvatinus
Включайте в ручную шпиндель из программы (можете нажать на F5) и прислушайтесь, есть ли щелчок реле(примерно куда кабель подключен)...

пробовал,щелчков нет.так же не реагирует. щелчки есть при включении компа,например станок включен,комп нет,включаем комп,слышен щелчек,далее пока винда грузится еще пару щелчков и тишина. потом при запуске мач3 слышен еще один щелчек и лпмпочка на плате станка гаснет.

0

7

kuvatinus написал(а):

можно вытащить провод LPT и шпиндель начинает работать

Если меняли компьютер и изменений нет,замените кабель LPT,похоже в нём причина.

0

8

У шпинделя обороты регулируются (раньше регулировались), чем он управляется реле? Попробуйте все пошагово проверить. Если оси работают и провод ЛПТ не "ломали" скорее он- провод, нормальный. Может настройки в масн слетели на управление шпинделем?

0

9

kuvatinus
По ходу у вас сбиты настройки или, как предположил appo... Вы можете самостоятельно проверить соответствующие настройки?

0

10

коль про шпиндель речь пошла: как на DC шпинделе фильтр сделать? Может кондер какой воткнуть, поможет? На питание керамический между + и - ?

А то сейчас включаешь шпиндель, рябь по монитору идет, фонит от него прилично :)

0

11

0.1 мкФ х 400 (600) V, может и на цепь питания монитора. Конденсатор как можно ближе к шпинделю. может попробовать подбирать емкость. Нужно высокочастотную помеху "загасить", поэтому чем ближе к источнику помехи - тем лучше.

0

12

да на монитор, мне особо-то пофиг, не думаю, что он накроется от этого, зато он хорошим "монитором" помех является визуальным, а вот наводки на электронику дабы избежать и хочется загасить лишние помехи. Тем более многие пишут, что после замены родных щеток начинается полный атас, искрят, фонят и тп - вот хочется заранее обезопасится по максимуму :)  Контроллеры то можно и в железный ящик сунуть, но ШД, хоть и в металле все, все равно в непосредственной близости, да и на провода где-то да и ляжет наводка, хоть в экране хоть без.

Кондер так понимаю в параллель ставить, не в разрыв плюса?

Отредактировано achuser (14-06-2016 03:43:12)

0

13

абсолютно верно, в параллель ставить. Я на мониторе и не концентрирую внимание... Ставьте конденсатор поближе к шпинделю - это первое. Второе- обязательно экранированные провода управления. Желательно силовые и сигнальные провода разнести друг от друга по разным кабель-каналам на расстояние не менее 30 см.

0

14

kuvatinus написал(а):

пробовал,щелчков нет.так же не реагирует. щелчки есть при включении компа,например станок включен,комп нет,включаем комп,слышен щелчек,далее пока винда грузится еще пару щелчков и тишина. потом при запуске мач3 слышен еще один щелчек и лпмпочка на плате станка гаснет.

Подкачка пина в МАЧЕ включена на пин реле шпинделя ?

0

15

Сегодня поставил кондер, искал плоские сначала, но так нигде напряжение которое держат найти не смог, поставил советский бочонок 0.1 мкф 400В. Сразу помехи ушли с монитора, звук шпинделя маленько поменялся. Но при этом БП тсал дико греться, хорошо, что заметил вовремя.

Далее, когда кондер стоит - напряжение можно измерить, когда снят - цешка не кажет. Так понимаю, блок выдает мелкий импульс, что-то типо ШИМ там иль чего еще, кондер это сглаживает, т.к. заряд принимает, и в итоге стабильные 105 В кажет.

Что еще замечено: при вкл шпинделя в Маче врубается "Сброс". Так понимаю, идет наводка на какой-то пин, и типо вклчюается Е-стоп.

Так же уходит Х постоянно, при этом Зет и У не гуляют, ну У мало нагрузки, но Зет если бы так скакала, то сразу было бы видно.

Зашел в мач, отключил все лигние пины - концевики, енабл и тп, на Х стояло актив одна галочка, убрал на всяк случай и ее.

Запустил, все заработало, монитор вроде меньше рябит, Х крутит, прибавляю скорость по Х в Маче до 110-120% и сразу пропуски (подача всего 30 была). Убираю, дальше тоже пропуски но меньше.

Включаю галочки что снимал (правда концевики не включил) - все так же как и было, т.е. ничего не блокируется, ряби столько же.

Вот и как понять в чем дело :)

0

16

По конденсаторам: если начал греться блок питания, при подключении кондёра - это совсем не гуд, значит уплыла (снизилась) емкость электролитических конденсаторов в блоке питания. Надо их менять. ... А еще - точно шпиндель постоянного тока??? ну ни разу не должен греться. Можно попробовать поставить и меньшей емкости - 0,01 мкФ напряжение тоже не менее 400 В. Обычно в хороших БП они штатно стоят. Как раз (вы правы) убивают высокочастотную составляющую преобразователя импульсных блоков питания. Кондеры "бочонком" имеют большой ток утечки.

0

17

Я предполагаю иную причину. В БП, так понимаю, ШИМ. Импульс на шпиндель идет 37-50 Кгц, их на мониторе мы и видим как помехи. Я в электронике не силен, н опо логике - раз без кондера напряжение на БП не измерить, то с кондером теряется импульс, и получается, к примеру, силовой транзистор все время открыт, а не закрывается-открывается с частотой 37 кгц. Через него течет вечный ток и он шибко греется.

Хотя может нагрев шел от трансформаторов-катушек.

В общем я далек от электроники, но предположить нечто подобное возможно, что кондер выровнял пульсации и это БП совсем не понравилось.

0

18

Всей "картины" не вижу, предполагаю, что если идет речь  о БП, то шпиндель постоянного тока. Обычно стоит шпиндель-асинхронник и частотник. Встречал шпинделя постоянного тока, диапазон изменения оборотов очень невелик, управление напряжением. Из этих соображений и рассуждаю.

Отредактировано nautiluss (17-06-2016 16:40:37)

0

19

шпиндель обычный китайский с щетками 500 вт, БП в комплекте к нему же

0

20

Сегодня пробовал кондер 0.01 400в (БМТ-2), может конечно им уже хана от времени, но грелось не сильно, и сам кондер не шибко нагрелся.
Но эффекта при этом никакого, напруга не замеряется, т.е. транзистор "перебарывает" конденсатор, помехи прут так же.

Феррита не нашел чтоб провод намотать, буду еще этот вариант пробовать.

Провод от шпинделя весь экранировал, тоже толку нет.

0

21

Всем здрасте
Нужен совет
С Блока управления шпиндель запускается и обороты регулируются, а через mach3 все тухло при нажатии f5 или запуске УП есть щелчек в блоке и на этом все .

И ещё подскажите при ручном управлении станком , я про оси XYZ при подкатывание к краю и срабатыванию концевика движение должно остановится, или нет, ???
У меня он не останавливается, вплоть до неприятного звука. А припозиционирования нуля концевики срабатывают нормально.

Отредактировано Apollion82 (15-10-2016 21:07:28)

0

22

Вот снял видео
https://youtu.be/74AaRysssBE

0

23

Apollion82 написал(а):

С Блока управления шпиндель запускается и обороты регулируются, а через mach3 все тухло


Это потому, что инвертор не настроен на управление из программы!

Apollion82 написал(а):

И ещё подскажите при ручном управлении станком , я про оси XYZ при подкатывание к краю и срабатыванию концевика движение должно остановится, или нет, ???


Нет, если не настроены лимиты. Судя по вашим вопросам вы достаточно далеки от Мача :yep: Почитайте немного о настройках программы, будет полезно!

Отредактировано skedram (16-10-2016 08:38:41)

0

24

skedram написал(а):

Это потому, что инвертор не настроен на управление из программы!

Нет, если не настроены лимиты. Судя по вашим вопросам вы достаточно далеки от Мача  Почитайте немного о настройках программы, будет полезно!

Отредактировано skedram (Вчера 11:38:41)

Спасибо . И да, вы правы я в этом нуб. Но ту инфу что я нашёл по mach3 я прочёл , но ощущение что она не полная есть, очень большая просьба дайте ссылку или опишите пошагово что делать , буду очень вам признателен.

0

25

Разобрался. Дело было в настройках частотника.

0

26

Apollion82 написал(а):

Вот снял видео
https://youtu.be/74AaRysssBE


У меня точно такая же проблема, один в один.
Частотник и шпиндель такие же

Как вам удалось решить проблему?

0


Вы здесь » Форум клана ЧПУшников » Станки с ЧПУ » Шпиндель и mach3 не дружат...