Форум клана ЧПУшников

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.



Mach3 -2часть

Сообщений 651 страница 700 из 771

651

albel1977 написал(а):

На тестах с перемещением G1 все ОК. С изменением скорости в процентном отношении с этой командой все понятно.
Как уменьшить скорость перемещений на G0 не знаю(( В этом и был мой вопрос.

Главное меню - Config - Motor tuning
http://s019.radikal.ru/i626/1703/a4/50a2da889bb0.jpg

0

652

Перекиньте на контроллере ось z и х или у и посмотрите как имитацию касания отработает

0

653

Доброго времени суток!

Собираю не первый станок, но с таким не сталкивался.
Плата управления китайская 5 осей http://www.omc-stepperonline.com/images ... -v2_01.jpg
Драйвера TB6600
Двигатели NEMA 23
Собрал станок поменьше для более точных работ, включил, настроил, выпилил пару деталек в том числе и с поворотной осью.
После удачного запуска начал автоматизировать процессы, AUTO Z, поиск центра, щуп, дом и прочее. Столкнулся с проблемой.

1. LPT порт у меня в закладке "Ресурсы" имеется два адреса 0x378 и вторая строка 0x778. (ковырялся в BIOS менял настройки порта NORMAL, ECP, Bi)
В настройках в mach3 указан адрес порта 0x778, станок работает прекрасно передвигается. НО как только запускаю шпиндель, все движения становятся рывками, продвинулась ось, остановилась, продвинулась и снова остановилась.
2. Написал скрипт для определения Авто нуля по Z. Настроил порт 11 в заладке Input, НО при замыкании пробника, ничего не происходит. Начал коваться и обнаружил, что когда выставляю адрес порта 0x378 работают все концевики, датчики и не работают двигатели При нажатии на стрелки Влево движки встают в удержание, вправо движки отпускает (цифры на mach бегут) и так с любым направлением. Когда выставляю адрес порта 0x778 работаю двигатели и не работают датчики. Поставил другой копм Win 7 32bit, у него только один адрес LPT 0x378. Не работают движки, работают только датчики.
Помогите, кто сталкивался с проблемой или знает ее решение)

http://sd.uploads.ru/t/kqiL8.png
http://s4.uploads.ru/t/U8RpB.png
http://sa.uploads.ru/t/mF0I7.png
http://sh.uploads.ru/t/8G42S.png
http://sf.uploads.ru/t/NEfex.png

Отредактировано 3bugatti (09-03-2017 22:22:09)

0

654

3bugatti написал(а):

Доброго времени суток!
1. LPT порт у меня в закладке "Ресурсы" имеется два адреса 0x378 и вторая строка 0x778. (ковырялся в BIOS менял настройки порта NORMAL, ECP, Bi)
В настройках в mach3 указан адрес порта 0x778, станок работает прекрасно передвигается. НО как только запускаю шпиндель, все движения становятся рывками, продвинулась ось, остановилась, продвинулась и снова остановилась.
2. Написал скрипт для определения Авто нуля по Z. Настроил порт 11 в заладке Input, НО при замыкании пробника, ничего не происходит. Начал коваться и обнаружил, что когда выставляю адрес порта 0x378 работают все концевики, датчики и не работают двигатели При нажатии на стрелки Влево движки встают в удержание, вправо движки отпускает (цифры на mach бегут) и так с любым направлением. Когда выставляю адрес порта 0x778 работаю двигатели и не работают датчики. Поставил другой копм Win 7 32bit, у него только один адрес LPT 0x378. Не работают движки, работают только датчики.
Помогите, кто сталкивался с проблемой или знает ее решение)
(Сегодня 22:22:09)

Наугад:
1. Снести LPT порт в диспетчере и установить его заново(по идее встанет автоматом)
2. Попробовать в матче поставить обе галки на портах  0x378 и 0x778 (Port Enable) и соответственно распределить двигатели и и датчики по номерам этих портов.

0

655

Енот 1 написал(а):

Наугад:
1. Снести LPT порт в диспетчере и установить его заново(по идее встанет автоматом)
2. Попробовать в матче поставить обе галки на портах  0x378 и 0x778 (Port Enable) и соответственно распределить двигатели и и датчики по номерам этих портов.

Порт сносил, ставил, менял комп, винду. не помогает.
установка двух галочек просто дезактивирует все, только перезагрузка возвращает работоспособность порту или его переустановка.

0

656

Благодаря активной помощи Гуру Flint2015 вчера вроде победили Масн, с утра продолжает работать правильно. Причина не найдена, но устранена полной переустановкой. Спасибо ещё раз огромное. Но чувствую ещё мучения ни кончились, надо поиск нуля для 4-х осевого настроить, будут проблемы, буду писать. И спасибо всем.

0

657

Сан_Саныч написал(а):

albel1977
По моему в настройках моторов, уменьшите максимальную скорость.

Подпись автора

    Что нас не убивает, то делает нас сильнее.

Может подскажите, где эти настройки в этой конфигурации
В стандартном Маче есть вкладка, где в этой конфигурации не знаю((
http://s6.uploads.ru/t/rOg4A.jpg
http://sd.uploads.ru/t/pFPMi.jpg

0

658

albel1977 вам же DeKot вверху показал... это из меню Config-Motor Tuning

0

659

3bugatti написал(а):

Порт сносил, ставил, менял комп, винду. не помогает.
установка двух галочек просто дезактивирует все, только перезагрузка возвращает работоспособность порту или его переустановка.

  Тогда проверяйте по порядку :
1.В настройках биоса, параллельный порт - SPP.
2.Там же в биосе выбираем адрес, например 378/...
3. Свежая винда, адрес порта в диспетчере один!
4. Заземление всего, что имеет заземляющий контакт( станок, экраны проводов, комп, оборудование итд)
Всё должно работать.

0

660

Сан_Саныч написал(а):

Благодаря активной помощи Гуру Flint2015 вчера вроде победили Масн, с утра продолжает работать правильно. Причина не найдена, но устранена полной переустановкой. Спасибо ещё раз огромное. Но чувствую ещё мучения ни кончились, надо поиск нуля для 4-х осевого настроить, будут проблемы, буду писать. И спасибо всем.

Может будет полезно. Здесь скрипты кто-то писал по поиску краев, немного переработать и будет поиск центра 4-й оси
http://www.jportal.ru/forum/forum53/topic16041/

0

661

Сан_Саныч написал(а):

albel1977 вам же DeKot вверху показал... это из меню Config-Motor Tuning

Подпись автора

    Что нас не убивает, то делает нас сильнее.

К сожалению у меня конфигурация Version R3.042.029
Там во вкладке Config только эти параметры
http://s8.uploads.ru/t/ELTcR.png

0

662

albel1977 написал(а):

К сожалению у меня конфигурация Version R3.042.029
Там во вкладке Config только эти параметры

Нажимаем View, в ней выбираем Load Screenset,  в выпавшем окне ищем стандартный скрин 1024set, загружаем его, в нужном окне появяться все нужные закладки, после всё сохраняем и работаем.

0

663

Приветствую! кто нибудь пользовался утилитой в mach3 для сканирования поверхности?
http://sg.uploads.ru/t/vdTwc.jpg
Пробую, вроде все работает создает G код, при запуске спрашивает в каком файле сохранить сканированные координаты, все указываю затем запуск и проходит успешное сканирование. Затем захожу в паку где сохраняем файл, файл присутствует. Но при открытии он абсолютно пуст, нет ни одной координаты.
Может кто сталкивался с такой проблемой?
http://sa.uploads.ru/t/0Mk9n.jpg
Вот сам G код созданный mach3 для сканирования.

КОД

(Digitize File)
M40
G92X0Y0Z0
F100
G0X0Y0Z1
G31 Z-1
G0 Z1
G0X20Y0Z1
G31 Z-1
G0 Z1
G0X40Y0Z1
G31 Z-1
G0 Z1
G0X60Y0Z1
G31 Z-1
G0 Z1
G0X80Y0Z1
G31 Z-1
G0 Z1
G0X100Y0Z1
G31 Z-1
G0 Z1
G0X100Y20Z1
G31 Z-1
G0 Z1
G0X80Y20Z1
G31 Z-1
G0 Z1
G0X60Y20Z1
G31 Z-1
G0 Z1
G0X40Y20Z1
G31 Z-1
G0 Z1
G0X20Y20Z1
G31 Z-1
G0 Z1
G0X0Y20Z1
G31 Z-1
G0 Z1
G0X0Y40Z1
G31 Z-1
G0 Z1
G0X20Y40Z1
G31 Z-1
G0 Z1
G0X40Y40Z1
G31 Z-1
G0 Z1
G0X60Y40Z1
G31 Z-1
G0 Z1
G0X80Y40Z1
G31 Z-1
G0 Z1
G0X100Y40Z1
G31 Z-1
G0 Z1
G0X100Y60Z1
G31 Z-1
G0 Z1
G0X80Y60Z1
G31 Z-1
G0 Z1
G0X60Y60Z1
G31 Z-1
G0 Z1
G0X40Y60Z1
G31 Z-1
G0 Z1
G0X20Y60Z1
G31 Z-1
G0 Z1
G0X0Y60Z1
G31 Z-1
G0 Z1
G0X0Y80Z1
G31 Z-1
G0 Z1
G0X20Y80Z1
G31 Z-1
G0 Z1
G0X40Y80Z1
G31 Z-1
G0 Z1
G0X60Y80Z1
G31 Z-1
G0 Z1
G0X80Y80Z1
G31 Z-1
G0 Z1
G0X100Y80Z1
G31 Z-1
G0 Z1
G0X100Y100Z1
G31 Z-1
G0 Z1
G0X80Y100Z1
G31 Z-1
G0 Z1
G0X60Y100Z1
G31 Z-1
G0 Z1
G0X40Y100Z1
G31 Z-1
G0 Z1
G0X20Y100Z1
G31 Z-1
G0 Z1
G0X0Y100Z1
G31 Z-1
G0 Z1
G0X0Y100Z1
G0X0Y0Z1
G0X0Y0Z0
M30

0

664

Доброе время суток!
Может кто сталкивался .
Запускаю Mach3 , синий экран и уходит в перезагрузку .. 
P.S  Это первое знакомство с ЧПУ ..

0

665

Aleks709 написал(а):

Доброе время суток!
Может кто сталкивался .
Запускаю Mach3 , синий экран и уходит в перезагрузку .. 
P.S  Это первое знакомство с ЧПУ ..

Как когда экран смерти,там указывается номер ошибки.Надо его переписать-глянуть.И от этого уже плясать.Комп мож железо не тянет,или еще чего...

0

666

Flint2015 написал(а):

albel1977 написал(а):

    К сожалению у меня конфигурация Version R3.042.029
    Там во вкладке Config только эти параметры

Нажимаем View, в ней выбираем Load Screenset,  в выпавшем окне ищем стандартный скрин 1024set, загружаем его, в нужном окне появяться все нужные закладки, после всё сохраняем и работаем.

Стандартного скрина 1024.set в этой конфигурации  не нашел(( искал по всей установленной папке((
Взял из другого Mach. Но это ничего не дало. В меню доп вкладок не появилось((http://sa.uploads.ru/t/0T3YV.png

0

667

albel1977
Пост № 622 в этой теме... от коллеги Flint2015 скачайте и будет вам счастье.

0

668

albel1977
если вы вдруг не видите скрытый текст, напишите в личку.

0

669

Подскажите где в настройках масн3 можно установить значение длительности задержки перед сменой направления движения по осям и какое значение нужно выставлять .?

0

670

rockzara написал(а):

Подскажите где в настройках масн3 можно установить значение длительности задержки перед сменой направления движения по осям и какое значение нужно выставлять .?

http://s1.uploads.ru/t/NlyaS.jpg
галочка на constant- обработка с постоянной скоростью
галочка exact - обработка с точными остановками в узлах, но общая скорость обработки резко снизится.

+1

671

нужно обработать большой файл, сам код весит около 20мб, загружаю, срабатывает watch dog trigger, в холостую запускаю станок, и комп подтормаживает происходит дикий пропуск шагов, работать не возможно, если работать с мелкими файлами до 5мб то все норм, это вообще как-то лечится? или выход резать код по частям

0

672

stapelmoor написал(а):

watch dog


А он у вас отключен в general config ?

0

673

stapelmoor написал(а):

это вообще как-то лечится? или выход резать код по частям

Попробуйте отключить
http://sh.uploads.ru/t/nAzdu.png

Мне помогало при большом файле

Отредактировано bordyn (16-03-2017 12:29:48)

0

674

Может все таки вот тут.http://sf.uploads.ru/t/1qYcR.jpg

0

675

Как в матче отключить измерение инструмента после каждой смены?

0

676

vis написал(а):

Как в матче отключить измерение инструмента после каждой смены?

Для чего вам это нужно, и как станок будет новую фрезу приводить в ноль Z координаты?

0

677

Хотелось бы чтоб матч брал параметры фрез из таблицы, а не каждый раз после смены ехал на датчик.

0

678

vis написал(а):

Хотелось бы чтоб матч брал параметры фрез из таблицы, а не каждый раз после смены ехал на датчик.

масн будет брать параметр из таблицы, а где у вас уверенность что вы сможете выставить с точностью до десятки все фрезы по вылету из патронов?

0

679

Flint2015 написал(а):

масн будет брать параметр из таблицы, а где у вас уверенность что вы сможете выставить с точностью до десятки все фрезы по вылету из патронов?

В этом и проблема что фрезы стоят на разном расстоянии, а хотелось бы чтоб он где то записывал эту разницу. Просто когда режешь в день по 50 трех фрезных накладок измерение после каждой смены немного напрягает.

0

680

vis написал(а):

В этом и проблема что фрезы стоят на разном расстоянии, а хотелось бы чтоб он где то записывал эту разницу. Просто когда режешь в день по 50 трех фрезных накладок измерение после каждой смены немного напрягает.

Как вариант ускорения данной процедуры, переустановка датчика, поближе к инструменту и соответствено изменение скоростей перемещения.
Это стандартная процедура для всех станков применяющих М корректировку инструмента, но есть ещё L корректировка, с записью высоты инструмента в базу, но такой способ в основном используется в токарных станках.
И для этого вам нужно переписывать макрос смены инструмента.

0

681

Flint2015 написал(а):

Как вариант ускорения данной процедуры, переустановка датчика, поближе к инструменту и соответствено изменение скоростей перемещения.
Это стандартная процедура для всех станков применяющих М корректировку инструмента, но есть ещё L корректировка, с записью высоты инструмента в базу, но такой способ в основном используется в токарных станках.
И для этого вам нужно переписывать макрос смены инструмента.

Flint2015 написал(а):

Как вариант ускорения данной процедуры, переустановка датчика, поближе к инструменту и соответствено изменение скоростей перемещения.
Это стандартная процедура для всех станков применяющих М корректировку инструмента, но есть ещё L корректировка, с записью высоты инструмента в базу, но такой способ в основном используется в токарных станках.
И для этого вам нужно переписывать макрос смены инструмента.

А как правильно? Нужно переписать макрос М6 или же надо создавать новый дополнительный?

Отредактировано vis (18-03-2017 14:12:31)

0

682

vis написал(а):

А как правильно? Нужно переписать макрос М6 или же надо создавать новый дополнительный?

Отредактировано vis (Сегодня 18:12:31)

Лучше конечно новый, и обратиться с таким вопросом к людям кто занимался или занимается макросами для масн3.

0

683

Где ж таких найти?))

0

684

Добрый день под скажите пожалуйста собрал самодельную плазму подключился тсн proma 150  прописал пины on up down все сигналы доходят в последней закладке  лампочки загораются все работает а ось z стоит на месте запускают резкую down up на тсн моргает а z стоит мёртвой

0

685

filichka999 написал(а):

Добрый день под скажите пожалуйста собрал самодельную плазму подключился тсн proma 150  прописал пины on up down все сигналы доходят в последней закладке  лампочки загораются все работает а ось z стоит на месте запускают резкую down up на тсн моргает а z стоит мёртвой

У вас к данному девайсу должен быть короткий но полный мануал по настройке.
Вот в этом окне настривали?
http://se.uploads.ru/t/JtlTR.jpg
http://proma-elektronika.com/download/PDF/thc150_ru.pdf
Очень дёрганый аппарат, не любит пустоты, не допускайте вторичный проход плазмы по уже имеющемуся резу, резак будет клювать, если будет большое отверстие, то может клюнуть вниз и при дальнейшем движении, если привод станка мощный, запросто повредит плазматрон.

Отредактировано Flint2015 (27-03-2017 17:58:50)

0

686

Все настроил как в этом мануале и птичка в этом окне верхнюю поставил запускают тестевый режим тсн сигналы приходят работает прибывал привязать сигналы к кнопками клавиатуры ось зет стоит мертво
А может быть из-за того что мая левый просто в одном мануале вычитал что тсн работает только на лецинзионном маче

0

687

переподключил на лпт порт один сигнал заработал отстольные молчат напрямую подаю входные сигналы и из пяти то есть 10-13 и 15 пин работает только один 15 но перед тем как сносил винду работал только 10 то есть как я понимаю у меня в маче не работает функция тсн хотя фрезерный станок на этом маче работает на ура
может кто нибудь может поделиться рабочим мачем на котором работает плазма и работает функция тсн

0

688

filichka999 написал(а):

переподключил на лпт порт один сигнал заработал отстольные молчат напрямую подаю входные сигналы и из пяти то есть 10-13 и 15 пин работает только один 15 но перед тем как сносил винду работал только 10 то есть как я понимаю у меня в маче не работает функция тсн хотя фрезерный станок на этом маче работает на ура
может кто нибудь может поделиться рабочим мачем на котором работает плазма и работает функция тсн

тут посмотрите

Скрытый текст:

Для просмотра скрытого текста - войдите или зарегистрируйтесь.

0

689

Вчера фрезер работал нормальною Сегодня глючит и пишет "soft warning on y max"
Станок АМАН, программа Масн 3

0

690

добрый день может кто сталкивался с такой проблемой
вырезаю плазменной резкой рисунок и периодически когда станок начинает делать пробу прописанную в макросе м3 программа ловит глюк при отпускании в низ в именно в момент когда делает пробу и ни с токо сего ось зет начинает сначала в низ а потом в верх ити очень медленно такое ощущение что зависает мач
PS.MACH3  ЛИЦЕНЗИОННЫЙ
пробывал менять частоту нет ни какой разницы после того как происходит глюк останавливаю программу запускаю с нужной строки и через какое то время опять происходит тоже самое
может кто то сталкивался с такой проблемой

0

691

filichka999 написал(а):

добрый день может кто сталкивался с такой проблемой
вырезаю плазменной резкой рисунок и периодически когда станок начинает делать пробу прописанную в макросе м3 программа ловит глюк при отпускании в низ в именно в момент когда делает пробу и ни с токо сего ось зет начинает сначала в низ а потом в верх ити очень медленно такое ощущение что зависает мач
PS.MACH3  ЛИЦЕНЗИОННЫЙ
пробывал менять частоту нет ни какой разницы после того как происходит глюк останавливаю программу запускаю с нужной строки и через какое то время опять происходит тоже самое
может кто то сталкивался с такой проблемой

Что же вас всех тянет, загрузить по полной и так загруженную программу Масн3.
Было время, общался с Денисом с компании ПОМО, ребята начинали ещё с разработки своей ТНС, так вот у него, то же бзик наступил, сделать всё ни как у всех, а именно прописать макрос на М3 с поиском ноля заготовки, я его отговаривал но.......
В программе SheetCAM уже есть постпроцессоры с прописанной функцией поиска ноля заготовки и огромная разница в работе станка---------когда он выполняет чисто G-коды и когда выполняет по мимо основной программы ещё и дополнительные в виде макросов.

0

692

А КАК ЭТОТ ПОСТПРОЦЕССОР НАЗЫВАЕТСЯ ПОДСКАЖИТЕ ПОЖАЛУЙСТА ДЕЛО В ТОМ ЧТО ПЛАЗМУ ТОЛЬКО НАЧИНАЮ ОСВАИВАТЬ ДО ЭТОГО В ПЛОТНУЮ ПАРУ ЛЕТ ФРЕЗЕРОВКОЙ ЗАНИМАЛСЯ

0

693

filichka999 написал(а):

А КАК ЭТОТ ПОСТПРОЦЕССОР НАЗЫВАЕТСЯ ПОДСКАЖИТЕ ПОЖАЛУЙСТА ДЕЛО В ТОМ ЧТО ПЛАЗМУ ТОЛЬКО НАЧИНАЮ ОСВАИВАТЬ ДО ЭТОГО В ПЛОТНУЮ ПАРУ ЛЕТ ФРЕЗЕРОВКОЙ ЗАНИМАЛСЯ

там их несколько, более нормальный и стабильный Plasma THC300 - G31 - corner slowdown
                                                                                  Plasma THC300 - G31

Отредактировано Flint2015 (12-04-2017 18:19:21)

0

694

СПАСИБО БОЛЬШОЕ ПОЙДУ ПОПРОБУЮ СКАЖИТЕ А МАЧЕ НЕ НАДО G31 НЕ НАДО АКТИВИРОВАТЬ

0

695

filichka999 написал(а):

СПАСИБО БОЛЬШОЕ ПОЙДУ ПОПРОБУЮ СКАЖИТЕ А МАЧЕ НЕ НАДО G31 НЕ НАДО АКТИВИРОВАТЬ

Команда G31 позволяет производить перемещение осей в заданную позицию.

Использование команды G31 требует наличие датчика.

Перемещение по команде G31 производиться либо до достижения заданной позиции, либо до получения сигнала установленного дополнительно датчика (сигнала пропуска).


И не забудьте вернуть макрос М3 в первозданный вид.

Отредактировано Flint2015 (12-04-2017 18:44:46)

0

696

ЭТО Я ПОНИМАЮ ПРО М3
ТО ЕСТЬ ЕСЛИ У МЕНЯ СДЕЛАН ПЛАВАЮЩИЙ ПОДВЕС ЭТО У БУДЕТ СИГНАЛ ДАТЧИКА КОГДА ОН СРАБОТАЕТ ПРИ ОПУСКАНИИ В НИЗ

0

697

filichka999 написал(а):

ЭТО Я ПОНИМАЮ ПРО М3
ТО ЕСТЬ ЕСЛИ У МЕНЯ СДЕЛАН ПЛАВАЮЩИЙ ПОДВЕС ЭТО У БУДЕТ СИГНАЛ ДАТЧИКА КОГДА ОН СРАБОТАЕТ ПРИ ОПУСКАНИИ В НИЗ

алгоритм работы такой, в УП у вас будет команда на перемещение плазматрона в точку реза, после поступит команда G31 плазматрон пойдёт вниз до касания с металом, как только ваша конструкция отреагирует на поверхность, программа запишет ноль поверхности, и плазматрон поднимится на высоту пробоя металла, которую вы выставите в шееткаме, ЗАМЕР ПОВЕРХНОСТИ ПРОИЗВОДИТСЯ КАЖДЫЕ 500 мм вектора, тоесть не каждый прокол, а только когда протяжёность вектора превысит 500 мм.

0

698

Здравствуйте уважаемые форумчане!
Вчера резал ножки для будущего стола на 2,5 млн. строк, чистовая.
Когда ушел свет станок отработал где то 1 млн. строк. Так вот, пролистываю ползунок в маче-3 где то на 1 млн. нажимаю рун фром хе, программа начинает думать и обрывается на 340 тыс. строке и кнопка ресет начинает моргать.  строка  меняется, не именно на одной строке.
Где то с 20-30 раза получается.
Вопрос, может где то в мач-3 есть какая то  кнопка или может галочку какую поставить?
З.Ы. тоол пач который показывает модель в маче отключен.

0

699

Для мача это тяжёлая УП. Разбейте УП на две половины, а то и на 3 части с копированием и вставкой начал и концов программы.

0

700

Доброго вечера всем.

Возникла странная проблема с мачем. Отказывается работать 5-я ось. Станок был 3-х осевой (2 движка по Х, ось А подчинена Х средствами мача), решил добавить поворотную. Если подключить ее вместо любой из имеющихся - все работает. Если в "Ports and pins" отключить любую и включить ось В - все работает. Но стоит включить все 5 сразу - все встает колом. Координаты в маче меняются, но движки крутится отказываются, причем все. Максимум, если перезапустить мач, проезжает пару см и все, дальше та же картина. Подключено через LPT плату развязки на 5 осей. Может кто сталкивался с таким, куда копать?

0